OneVersion 3.2

A bungeecord plugin that forces players to use a minimum protocol level.

  1. johnnywoof
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    Details
    This plugin is a simple and lightweight bungeecord plugin that forces players joining through bungeecord to use a certain protocol.

    This plugin is very useful when all your spigot servers are updated to 1.9, but bungeecord is still allowing 1.8 clients to connect.

    Configuration
    Code (Text):

    #The message to show to players when they do not use the right protocol to connect
    kick-message: 'This server has been updated to 1.9!.newline.Please use the latest minecraft version'

    #The minimum protocol version players must have to connect
    #See this page for all protocol versions
    #http://wiki.vg/Protocol_version_numbers
    #Use the value -1 in order to require players to use the highest protocol level bungee supports.
    #For example, if -1 is set and bungeecord supports minecraft 1.9, only 1.9 players can connect.
    protocol-version: -1

    #Sets the protocol name. Do NOT use chat color in this.
    #Set to 'null' to disable changing the protocol name.
    #You can use https://dinnerbone.com/minecraft/tools/status/ to view how the name affects server pings.
    protocol-name: 'null'
     
    Source code is available on the github.

Recent Updates

  1. Fixed false outdated server messages
  2. Release 3.1
  3. New features

Recent Reviews

  1. StromkabelHD
    StromkabelHD
    5/5,
    Version: 3.2
    I use this plugin with the newest version today.
    No problems, nice to configurate :)
    And simple
  2. NumberDown
    NumberDown
    5/5,
    Version: 3.2
    Excellent BungeeCord plugin ! Great for an advenced bungeecord server.
    > Simple config.yml.
    > Plugin for advenced minecraft server.

    Keep going.
  3. realmpixel
    realmpixel
    5/5,
    Version: 1.0
    thank. ^u^ It is a great plugin for me.