PAPISignLite 2.0.0

Put placeholders supported by PlaceholderAPI on a sign.

  1. vk2gpz
    Contributors:
    vk2gpz
    This is a free (lite) version.

    This plugin allows you to put placeholders, which are supported by PlaceholderAPI on a sign.

    Since this is a 'lite' free version, you can put placeholders short enough to fit on a sign's single line. If you wish to use many placeholders, which are too long to fit in a sign line, you need to use PAPISign (premium).

    Commands:
    • /papisign [help] : displays the help menu.
    • /papisign reload : reloads this config file.
    • /papisign set <line number> <displayed string> <papi placeholder(s)> : sets the <papi placeholders> to the specified <line number> of the sign you're looking at. (This command is only available in the premium version.)
    Permissions:
    • papisign.reload : allows you to use the reload command.
    • papisign.set : allows you to use the set command. (This permission is only meaningful in the premium version.)
    Installation:
    Configuration:
    Code (Text):

    # +------------------------------------------------------------+ #
    # PAPISign Configuration
    # +------------------------------------------------------------+ #

    # NOTE: Do NOT put tabs anywhere in the config!

    Messages:
      ErrorMsg : "&c[PAPISign] : Some error occured."

    HelpMessages:
      banner:
        msg: "=== &e[&aPAPISign Commands List (%version%)&e] &r==="
      help:
        msg: "&a/papisign help : displays this help menu."
      reload:
        msg: "&a/papisign reload : reloads config file."
        permission: "papisign.reload"
      debug:
        msg: "&a/papisign debug <true|false> : turn on / off the debug mode."
        permission: "papisign.debug"
      set:
        msg: "&a/papisign set <line number> <displayed string> <papi> : sets the <papi> to the specified <line number> of the sign you're looking at.  (Premium feature)"
        permission: "papisign.set"

    # The maximum distance to be searched for a sign.
    # Do not make this value too big.
    MaxDistance: 5

    # this is a premium feature
    # you can configure the event process priority.
    EventPriorityMap:
      PlayerMoveEvent: "LOWEST"
     
    Donation:
    It would be greatly appreciated for your donation to continue providing support for this plugin.
    [​IMG]
    Niall7459 and aBo0oDGamer like this.

Recent Updates

  1. Gradlised.