PerWorldPlugins 1.1.0

Disable plugins in certain worlds [Now 1.11]

  1. SharerXYZ
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    PerWorldPlugins.jpg

    What does this plugin do, and how does it work?

    PerWorldPlugins will inject the Bukkit core with its own CommandMap as well as changing how the event system works using some neat (and totally not hacky in any way) tricks. This allows you to control which plugins receive the events needed to function, and more importantly, where they receive those events. Using this plugin, you can block plugins in certain worlds. If you're hosting a hybrid server, you're probably overflowing with excitement. Sick of people using mcMMO in your minigames? Block mcMMO in the minigames world! Don't like LWC in your hardcore world? Block that, too!

    What's new?

    Now our plugin support Spigot 1.11 servers!

    Configuration

    This is an example of the config.

    limit:
    WorldEdit:
    - world
    - world_nether
    ModReq: []

    The configuration of PerWorldPlugins is simple and easy. Referring to the example above, WorldEdit would only work in the worlds 'world' and 'world_nether'. However, ModReq will work in any world.

    If you want to support the plugin:

    Click here

    REMEMBER: If a plugin has no world list, it will work in every world.

    Note: Do not use /reload.
    Plugin is java 8 only.

Recent Updates

  1. New command!
  2. Bug fixed
  3. 1.11 update

Recent Reviews

  1. BrayanPS
    BrayanPS
    5/5,
    Version: 1.1.0
    ---------------------------------------------

    Update 1.12.1

    ---------------------------------------------
  2. rexvonzombie
    rexvonzombie
    3/5,
    Version: 1.1.0
    This barely works on 1.12.1, I'm also getting the error Enabled plugin with unregistered PluginClassLoader ***PluginName*** on almost every single plugin I have. Please update this to 1.12.1.
  3. ImaCoolDude
    ImaCoolDude
    5/5,
    Version: 1.1.0
  4. Achaius
    Achaius
    5/5,
    Version: 1.1.0
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Love the new /pwp reload command! Thank you for this awesome plugin!
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  5. simonhudik
    simonhudik
    5/5,
    Version: 1.1.0
    Amazing Plugin!
    Thanks for making it : ) It works on 1.12 if anyone is wondering
  6. Kems_11
    Kems_11
    4/5,
    Version: 1.1.0
    good plugin but wenn it's uptated to 1.12
    Good luck for future and i waiting the update ;)
  7. gamer9797
    gamer9797
    5/5,
    Version: 1.1.0
    Great plugin but doesn't work on the latest version of the game. Hopefully won't be months before an update.
  8. edwardtakev
    edwardtakev
    5/5,
    Version: 1.1.0
    the plugin is great i hope 1.12 update come soon ! because i am updated to 1.12 !
  9. SuperDev
    SuperDev
    5/5,
    Version: 1.1.0
    Nice plugin! I need it for my server and doesn't require any other plugin! I share it with my friends!
  10. Olchaldir
    Olchaldir
    5/5,
    Version: 1.1.0
    nice plugin, hope for 1.12 version ;-) it's very useful for my server and simply to install and use.
    1. SharerXYZ
      Author's Response
      Thanks for the 5 stars rating! I will try to update it