PluginFixer 1.0

SpecialSource extension to fix issues with renamed sound-names

  1. ghac
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    This resource allows to update most of the existing 1.7/1.8 plugins to 1.9/1.10. It's based on SpecialSource by md_5 and therefor fixes some changes with methods, but the enums are not replaced properly. This resource allows to also update sounds to their new 1.9+ identification.

    To use SpecialSource, get the SpecialSource.jar from either the BuildData/bin/ folder (when using BuildTools) or download it here.

    After downloading the jar-file, download the resource and extract the .csrg-file to the same folder as SpecialSource is located. Also add the plugin you want to fix to that folder.
    Now open your console, navigate to that folder and run the following command:

    Code (Text):
    java -jar SpecialSource.jar map -m deprecation-mappings.csrg -i YOURPLUGIN.jar -o YOURPLUGIN-fixed.jar
    The fixed file is named YOURPLUGIN-fixed.jar and should be able to run on 1.9/1.10-servers.

    Have fun!
    KempitPlay and i9hdkill like this.

Recent Reviews

  1. KempitPlay
    KempitPlay
    5/5,
    Version: 1.0
    Спасибо очень помогли! но есть все ровно не большой минус не все плагины он может перевести на новые версии к примеру плагин: EchoPet он не хочет переводиться.. но я нашел замену ему! но главное что можно большинство плагинов перевести.
  2. belfedia
    belfedia
    5/5,
    Version: 1.0
    This save me, why isn't include in spigot package ? I don't know but i can say it working very well and is very usefull :)