ProRPGItems (rpg style item creation) 1.0.2

Make custom items in an RPG style

  1. goflish
    Native Minecraft Version:
    1.16
    Tested Minecraft Versions:
    • 1.14
    • 1.15
    • 1.16
    • 1.17
    Source Code:
    https://github.com/promcteam/prorpgitems
    Contributors:
    Travja, Spark
    Dependency Plugin (required)
    You can download it here.

    Wiki | Discord | Issues | Suggestions | Premium

    Some of PRORPGITEM's features
    • Easily create custom items, items with skills attached, tiered random items generator, and more.
    • You can setup item restrictions for level and class requirements for items using supported plugins. (proskillapi, mcmmo, etc)
    • Create unlimited custom damage and defense types, like chaos, water, earth, etc.
    • Create custom arrows with different stats and custom ammo types for bows.
    • There are over 25 item stats to add to your weapons, armor and any other items you create.
    • Every feature is separated into modules with their own commands and permisisons.
    • Create buffs and consumables that increase stats like damage, defense, dodge chance and more.
    • Display combat types like damage dealt, damage taken with different sounds and effects per damage type. Supports holographic displays.
    • Drop manager for prorpg items with multipliers for permission groups, different settings for supported modules, with world/biome/region/entity white lists and black lists and more.
    • Create essences that can be socketed to items that give effects with options to add sounds, and more.
    • You can extract gems, essences and runes from items with a cost, supports Vault with Citizens trait support.
    • Create gems that can be socketed to items that give bonus stats.
    • Create items that need to be identified before the items reveal their stats.
    • You can use magic dust to increase the success rate of socketed items.
    • Allows players to create parties with lots of features like max party size with permission support to increase party size, party chat, drop settings for parties and more
    • Allows repair for items with custom durability using cost from experience, materials or money with Citizens trait support.
    • Resolve allows items to have their source materials extracted with many options.
    • Create runes that can be socketed to items that give potion effects with many options.
    • Create admin sell shops that allows player to sell their items based on item level, materials, item stats, damage, and more.
    • Create item sets that give bonuses based on how many pieces you are wearing.
    • Create untradeable items with soulbound with many options.
    Basic tutorial for creating items:



    Supports the following plugins:
    If there's another plugin you would like to see supported, join our discord and let us know!
    • ProSkillAPI
    • McMMO
    • MythicMobs
    • PwingRaces
    • Vault
    Are we not supporting your favorite plugin? Let us know in our discord: https://discord.gg/RhTyRReKyP

Recent Updates

  1. Prorpgitems Alpha 1.0.2
  2. Prorpgitems 1.0.1
  3. Prorpgitems Alpha 1.0.1

Recent Reviews

  1. liuhao666
    liuhao666
    5/5,
    Version: 5.10.2
    Sorry, I'm from China. I can't visit disharmony website. I can only comment on this mistake here. I can't find the following error. I hope you can fix it. The core comes from paper1.16.5. In addition, I hope you don't give up this plug-in

    [QuantumRPG] [Classes] Could not setup skill: Energy_Impact
    [19:06:57 WARN]: java.lang.NullPointerException
    [19:06:57 WARN]: at su.nexmedia.engine.utils.FileUT.copy(FileUT.java:19)
    [19:06:57 WARN]: at su.nightexpress.quantumrpg.modules.list.classes.api.IAbstractSkill.load(IAbstractSkill.java:70)
    [19:06:57 WARN]: at su.nightexpress.quantumrpg.modules.list.classes.ClassManager.setup(ClassManager.java:213)
    [19:06:57 WARN]: at su.nexmedia.engine.modules.IModule.load(IModule.java:37)
    [19:06:57 WARN]: at su.nexmedia.engine.modules.ModuleManager.register(ModuleManager.java:48)
    [19:06:57 WARN]: at su.nightexpress.quantumrpg.modules.ModuleCache.initialize(ModuleCache.java:76)
    [19:06:57 WARN]: at su.nightexpress.quantumrpg.QuantumRPG.enable(QuantumRPG.java:109)
    [19:06:57 WARN]: at su.nexmedia.engine.NexPlugin.loadManagers(NexPlugin.java:197)
    [19:06:57 WARN]: at su.nexmedia.engine.NexPlugin.onEnable(NexPlugin.java:88)
    [19:06:57 WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263)
    [19:06:57 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:380)
    [19:06:57 WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:483)
    [19:06:57 WARN]: at org.bukkit.craftbukkit.v1_16_R3.CraftServer.enablePlugin(CraftServer.java:501)
    [19:06:57 WARN]: at org.bukkit.craftbukkit.v1_16_R3.CraftServer.enablePlugins(CraftServer.java:415)
    [19:06:57 WARN]: at net.minecraft.server.v1_16_R3.MinecraftServer.loadWorld(MinecraftServer.java:464)
    [19:06:57 WARN]: at net.minecraft.server.v1_16_R3.DedicatedServer.init(DedicatedServer.java:239)
    [19:06:57 WARN]: at net.minecraft.server.v1_16_R3.MinecraftServer.w(MinecraftServer.java:935)
    [19:06:57 WARN]: at net.minecraft.server.v1_16_R3.MinecraftServer.lambda$a$0(MinecraftServer.java:173)
    [19:06:57 WARN]: at java.base/java.lang.Thread.run(Thread.java:832)
    1. goflish
  2. Shadowpauler
    Shadowpauler
    5/5,
    Version: 5.10.2
    How could I have missed this the second it came out? I've always supported QRPG and the developer for his kind support. He's gone through a lot to bring this project to you, and the new developer has brought a lot to offer on the table, to bring it for FREE to ALL of you! Thank you so much! :D
    1. goflish
      Author's Response
      thanks! if you have suggestions let us know on discord
  3. Zyluss
    Zyluss
    5/5,
    Version: 5.10.2
    Literally the best RPG Items plugin, awesome community, friendly development team and good support.

    10/10
    1. goflish
      Author's Response
      glad you like it!
  4. SancLovin
    SancLovin
    5/5,
    Version: 5.10.2
    Thanks for this plugin so i can make my own rpg server

    but where module location?
    1. goflish
      Author's Response