ProtocolSupport 4.28

Adds 1.12-1.4.7 clients support to your spigot 1.12.2 server

  1. Shevchik
    Source Code:
    https://github.com/ProtocolSupport/ProtocolSupport
    Contributors:
    Shevchik, 7kasper, MrPowerGamerBR, BrettplayMC, EntryPointKR, BeYkeRYkt
    [​IMG][​IMG][​IMG]

    Adds 1.12, 1.11.*, 1.10.*, 1.9.*, 1.8.*, 1.7.*, 1.6.*, 1.5.*, 1.4.7 clients support to your spigot 1.12.2 server

    Note:
    I'm only supporting latest protocolsupport dev build. Also use github issues to post issues, i'm not reading forum posts most of the time.

    Installation notice:
    If you have problems with suddenly all players disconnecting and server stops working, set use-native-transport in server.properties to false

    Usage notice:
    Do not attempt no load/unload this plugin dynamicly, it won't work. And that will never work. /reload command is blocked to prevent this plugin accidental reload.

    Development builds:
    http://build.true-games.org/job/ProtocolSupport/

    Addons:
    ProtocolSupportLegacySupport
    ProtocolSupportStuff
    ClientStats
    MrDienns, Lazo, tomikcz987 and 64 others like this.

Recent Updates

  1. 1.12.2
  2. Update to 1.12.1
  3. Update to 1.12

Recent Reviews

  1. MrPowerGamerBR
    MrPowerGamerBR
    5/5,
    Version: 4.28
    Awesome plugin, works fine if you read the plugin description (yes, it only works with 1.12.2, don't try using in other versions)

    This allows you to keep your server up to date against bugs/exploits, allows you to use new features for newer clients while still allowing older clients in your server.

    Also one of the contributors is very cute. :3
  2. MOHMOBILE2
    MOHMOBILE2
    5/5,
    Version: 4.28
    Very Good Plugin! I use it for about three months. No errors. It takes a bit long to load, but that was so far no problem.
  3. TeknosGamer58
    TeknosGamer58
    4/5,
    Version: 4.28
    This is a very good plugin to make older versions supported on my server. I run a 1.7 - 1.12.2 server. I have two problems though: When I ride a horse or pig in 1.7, I can't get it to move, and if I try to access the horse inventory, it automatically kicks me from the server. The version my server is hosted on is 1.12.2 and I use PaperSpigot. If you can, please reply to this review please. :)
  4. ItsJohnny
    ItsJohnny
    5/5,
    Version: 4.28
    what version of plugin do I use on version 1.8.8? when I want the server to be on 1.7.10?
  5. ThePandaWolf
    ThePandaWolf
    2/5,
    Version: 4.28
    Newiest version doesn't work. Just boot loops. As for the older versions of this plugin it works fine. Just doesn't allow 1.12.2 clients to join a 1.12.1 server. I hoped the new update would fix that, but I was clearly mistaken.
  6. Elguerrero
    Elguerrero
    5/5,
    Version: 4.28
    Amazing!:D This help me so much!:D Thanks!:D
    10000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  7. ExeoAge
    ExeoAge
    1/5,
    Version: 4.28
    bad it keeps crashing my server i tryed every way to see if it will work but it wont? please fix this?
  8. nati_dublin
    nati_dublin
    2/5,
    Version: 4.28
    New version protocolsupport not support blockversion + viaversion + new version protocolsupport (THIS IS NEEDED FOR VERSIONS 1.9+)
  9. RealSpooderCraft
    RealSpooderCraft
    5/5,
    Version: 4.28
    Can u please make it bungee plz. if it was that would so helpfull
    --------------
  10. EshanK711
    EshanK711
    5/5,
    Version: 4.28
    Amazing plugin! I had to update my server to 1.12.2 and update and reconfigure a bunch of plugins to get this to work. But in the end, it was worth it!