ProtocolSupportStuff 2.1.0

A plugin that does... stuff, I guess. Disable MC versions, remap items, pre-1.9 PvP and much more!

  1. Kastanjeboom
    Kastanjeboom
    4/5,
    Version: 2.1.0
  2. LeEdward
    LeEdward
    4/5,
    Version: 2.1.0
    If the plugin remaps blocks/items for older versions of minecraft, does that mean all new blocks on my server (i.e. 1.13.2 blocks) would be gone?
    1. MrPowerGamerBR
      Author's Response
      Nope, currently how ProtocolSupport works it remaps newer blocks (example: stained clay -> bricks) for older versions.

      Those remaps are made based on the "time to break the block", to avoid "are you hacking?" issues.

      However if you have a creative server or disabled the fast break hack protection, you don't need to worry about it and can remap those blocks to something else (example: stained clay to wool!)
  3. VidTu
    VidTu
    5/5,
    Version: 2.1.0
    Paper (Optional)?! This plugin don't start without paper!
    Sorry for my english. ;)
    1. MrPowerGamerBR
      Author's Response
      Yeah, the latest version here on Spigot is kinda buggy...

      Use the latest Jenkins build, it should work fine :)
  4. MrMuskle
    MrMuskle
    5/5,
    Version: 1.0.2
    I do not know what I would do without this plugin! Oh, I know it - I would let my server stuck on release 1.8.8.
  5. Big_SmO_oke
    Big_SmO_oke
    3/5,
    Version: 1.0.2
    Nice idea but a lot of bugs, when you configure an item (blocks work fine) the older versions have the godd item, lore and name, but if a 1.12.2 player give a totem to an 1.8 player even the 1.12.2 player see the totem in an armor_stand, and the totem don't work anymore...
    1. MrPowerGamerBR
      Author's Response
      This is an issue with how Minecraft's creative mode works, try giving an item in survival mode and see how it works fine.
  6. LinsaFTW
    LinsaFTW
    5/5,
    Version: 1.0.2
    Nice plugin to customize the blocks/items changed by ProtocolSupport.

    -----------------
  7. SirCodeBrahs
    SirCodeBrahs
    5/5,
    Version: 1.0.2
    Wonderful plugin this is an excellent help for my server. I will be able to do a lot of good things with this in the feature! Thank you.
  8. R00t
    R00t
    5/5,
    Version: 1.0.2
    No work pls give me chineese protocol phone support. Okay big boy? It is very recommended ChongChing4433356?














    (Works Fine.)
  9. kamazaki
    kamazaki
    1/5,
    Version: 1.0.2
    error please fix it :
    [12:48:01 ERROR]: Error occurred while enabling ProtocolSupportStuff v1.0.2 (Is it up to date?)
    java.lang.NoSuchFieldError: CONCRETE
    at protocolsupport.protocol.typeremapper.id.IdRemapper$BlockIdDataRemappingRegistry.applyDefaultRemaps(IdRemapper.java:29) ~[?:?]
    at protocolsupport.protocol.typeremapper.id.IdRemapper$BlockIdDataRemappingRegistry.<init>(IdRemapper.java:25) ~[?:?]
    at protocolsupport.protocol.typeremapper.id.IdRemapper.<clinit>(IdRemapper.java:21) ~[?:?]
    at protocolsupport.api.remapper.BlockRemapperControl.resetToDefault(BlockRemapperControl.java:17) ~[?:?]
    at net.pocketdreams.protocolsupportstuff.ProtocolSupportStuff.applyConfigChanges(ProtocolSupportStuff.kt:136) ~[?:?]
    at net.pocketdreams.protocolsupportstuff.ProtocolSupportStuff.onEnable(ProtocolSupportStuff.kt:103) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:271) ~[spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugin(CraftServer.java:376) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugins(CraftServer.java:326) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.MinecraftServer.t(MinecraftServer.java:421) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.MinecraftServer.l(MinecraftServer.java:382) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.MinecraftServer.a(MinecraftServer.java:337) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.DedicatedServer.init(DedicatedServer.java:272) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:544) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112]
    1. MrPowerGamerBR
      Author's Response
      Update your server before complaining about errors.
  10. symvizan
    symvizan
    5/5,
    Version: 1.0.2
    Looking for these EXACT features for years. Thank you for making this plugin, it's awesome!
  11. Choubatsu
    Choubatsu
    5/5,
    Version: 1.0.2
    Block hitting doesn't seems to be working with OldCOmbatMechanics.
    I have latest version of ProtocolLib installed, same with ProtocolSupport.
    1. MrPowerGamerBR
      Author's Response
      Did you enable the option in the config?

      If you still have issues, please comment in this plugin thread ^-^

      (Also, I don't know if it would *really* work like pre-1.9 PvP, I was never into PvP back in the day but I also wanted to fix the "sword blocking" for pre-1.9 clients, so I just sent the "shield blocking" packet everytime someone tried to sword block, however this doesn't 100% work due to how Minecraft works)
  12. ANDREI923
    ANDREI923
    5/5,
    Version: 1.0.0
    Been waiting for somthing like this for ProtocolSupport for a while now. Very great plugin.
  13. isaiah8139
    isaiah8139
    5/5,
    Version: 1.0.0
    Been waiting for somthing like this for ProtocolSupport for a while now. Very great plugin.