RankGrant+ ~ Give Ranks Through An Awesome GUI (/grant) 3.5.2

Give ranks with a reason and duration, all in an awesome GUI! Includes a logging system and more!

  1. Fixed GroupManager Detection

    Demeng7215
    • Fixed an issue where GroupManager could not be detected by the automatic permission plugin detection system.
  2. Add Notification Messages

    Demeng7215
    This update allows you to add "notification messages" which are sent to the player who is receiving the rank. Customizable in language.yml.

    YOU MUST DELETE YOUR LANGUAGE.YML AND RESTART YOUR SERVER FOR THIS UPDATE TO WORK.
    Byrontall and SKVIRLSOV like this.
  3. 1.14.4, Removed Permission Debug Message

    Demeng7215
    RankGrant+ native version is now 1.14.4. Keep in mind older/legacy versions will still work.
    Also removed an annoying debug message containing the rank's required permission. Apologies for any spam.
    buffer100901 likes this.
  4. Easier Setup, Customizable Slots, 1.14.3

    Demeng7215
    Thank you for waiting patiently for an update!
    • Easier setup for new users! The commands of your permission plugin are automatically detected and put into the configuration.yml for drag-and-drop use!
    • Customizable GUI size for the rank selection GUI and the reason selection GUI- take away the unnecessary slots! (multiple pages aren't supported yet)
    • Bug fixes!
    • New ASCII!
    • New logo!
    • New configuration.yml: Please delete your current and restart the...
  5. Direct Download

    Demeng7215
    RankGrant+ is now switching to a DIRECT download, which means you are able to download older versions- keeping in mind that you will not receive support for legacy releases.
  6. "Fixed" Moving Items in GUI

    Demeng7215
    This update prevents users from opening the GUI and nothing will happen if a player tries to execute /grant while the plugin is disabled.

    This feature has been implemented as many users are confused about why they are able to take out the GUI items. So, if nothing is happening if you are doing /grant, the plugin has been disabled and there was an error.
    usefulLynx65084 likes this.
  7. Acutally Fixed Startup Error

    Demeng7215
    The changes in 3.3.2 were reverted as they did not work.
    3.3.3 should actually fix the Unsupported Operation error.
  8. Fix UnsupportedOperationException and Ungranting Bug

    Demeng7215
    -If you were experiencing an UnsupportedOperationException issue at startup, this version should fix the error.
    -Fixed a not-so-critical ungranting bug.

    New Donation Link: https://ko-fi.com/Demeng7215
  9. Further Compatibility, Tons of Bug Fixes, 1.14 API

    Demeng7215
    Kind of a big and crucial update, but not enough for RankGrant+ 4 ;):

    -IMPORTANT: Completely scrapped the automatic Vault granting/ungranting due to issues that would take way too much effort to fix (and make compatible for every single permission plugin). You are now required to set commands!
    -Using the new 1.14 API to support 1.14 material enums and a bunch of other stuff!
    -Support for server versions 1.7.10 to 1.14.1!
    -Added a small, lightweight (and weak) reload...
  10. Item Color Support for Legacy Versions

    Demeng7215
    Support for all 1.13 materials has been added, even for older versions, after being requested by a lot of people! This includes colored items such as RED_WOOL.
    RankGrant+ should work with 1.14, but will not support the new materials added in 1.14.

    MVP of this update:
    upload_2019-4-30_17-23-11.png
    upload_2019-4-30_17-23-32.png