Remain 3.0.1

Make your plugin work on all Minecraft 1.13 till 1.7.10 flawlessly.

  1. kangarko
    Native Minecraft Version:
    1.13
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    Contributors:
    MineAcademy.org
    This plugin has been featured on... [​IMG]


    Remain </>
    Hate how updates break your plugins? Stop wasting your time with Remain.

    Remain makes your plugin work on Minecraft 1.13.2 and 1.12.2 even back down to Minecraft 1.7.10 without any extra code, frustration and hours wasted away! All you need to do is to simply use Remain's classes instead of the one Spigot provides, and on the next update we do the hard work for you.

    Today, around 20% of all users still run their servers on Minecraft 1.8.8. Since Minecraft 1.13 came out, many methods broke and developers many started to support their plugins only running the latest version.

    For documentation and full source code, please see:
    https://www.github.com/kangarko/remain

    Features
    • Use Minecraft 1.12 and 1.13 material names and remain compatible on both MC.
    • Sound class to send sounds from MC 1.7.10 till 1.13 and newer.
    • Send Boss Bar on all MC versions
    • Send Title and Subtitle on all MC versions
    • Send Action Bar on all MC versions
    • Edit NBT tags for items and entities on all MC versions
    • Send attributes on all MC versions
    • Send particles on all MC versions
    • Set persistent metadata on all MC versions
    • Set monster eggs on all MC versions
    • Set potions on all MC versions
    • ...and much more!

    Installation
    1. You need to shade the sources directly within your plugin. Please see our GitHub on how to do this.
    2. Set your plugin's instance via Remain#setPlugin

    How to use
    For documentation and full source code, please see:
    https://www.github.com/kangarko/remain


    Requirements
    Java 8 or newer
    Spigot 1.7.10 or greater


    Legal - Please read
    Commercial and non-commercial use allowed as long as the reference to original author is provided.

    You can use Remain in all of your plugins, both free and premium, both obfuscated and non-obfuscated. However, for any plugin you release on Spigot, MCMarket or anywhere else, you must provide credit to Remain with a clear link to this page on your Overview.

    Thanks.


    Copyright 2019 © | All Right Reserved.
    thebfmg, calf8876, bertek41 and 5 others like this.

Recent Updates

  1. 3.0.1
  2. 3.0.0

Recent Reviews

  1. Honey
    Honey
    5/5,
    Version: 3.0.1
    Wow, I appreciate your efforts kangarko, this is really a deal breaker for alot of devs who don't want the headache of supporting different versions.
    1. kangarko
      Author's Response
      Thanks! We have been using it for years in our premium plugins but due increasing pain for lots of users and lack of solution from Spigot we decided to help the entire community by open sourcing it :) Enjoy!
  2. HexedHero
    HexedHero
    5/5,
    Version: 3.0.0
    Thank you so much for this, this is honestly what the community needs! Thank you.
    1. kangarko
      Author's Response
      Thanks so much!
  3. tucaofeng
    tucaofeng
    5/5,
    Version: 3.0.0
    Nice Work. It's of great importance to me.

    80 chars 80 chars 80 chars 80 chars 80 chars
    1. kangarko
      Author's Response
      Thanks so much!