RiLib 1

Library plugin for most of my plugins

  1. Felnstaren
    Native Minecraft Version:
    1.16
    Tested Minecraft Versions:
    • 1.16
    Source Code:
    https://github.com/RyanA3/RiLib/tree/master/RiLib
    This plugin offers no functionality, do not install it unless another plugin requires it.

    This is a library that I use to develop most of my plugins, it contains a lot of functionality that is commonly used across them (menus, config loading/saving, json messages, etc) If you'd like to use it as well, feel free to do so. There's a lot of better APIs out there, so I wouldn't suggest using this one, considering it is pretty scuffed. If there's something specific you're looking for, feel free to look through the source code and take segments of it, just make sure to credit the author somewhere.

    Small Libraries from other authors are found in the package other.<author>.<library>
    Some of these include;
    BananaPuncher714's NBTEditor - https://www.spigotmc.org/threads/269621/