RPG Regen [1.11->1.13] 1.6.0

The Best Configurable RPG Health Regen System

  1. V1.6.0 | Big Bug Fix + Potion Option Feature

    Gilles_M
    Important Update
    • Fixed a very important bug making the regeneration stacking multiple times, which could cause insane regeneration amount. Please update the plugin!
    • Added an option to put players in combat state if they consume any potion. I will add more customization about it in later updates (like deciding on what potions put the player in combat state or not)
    Important note:...
  2. V1.5.2 | Bug Fix

    Gilles_M
    Update:
    • Fixed a bug crashing the plugin and spamming the console with errors if the 'use-SkillAPI-experience-level' option is activated without SkillAPI being present
    Please if you notice any bug, let me know in the discussion section.
  3. V1.5.1 | SkillAPI Compatibility Update

    Gilles_M
    Update:
    • Added the possibility to modify the regen amount depending on the player's SkillAPI main class level
    • Fixed a bug where players with more than 20 hp (default max value) couldn't regenerate all their health
    • I've made the config file a bit more clear (and nice). Check the ressource Overview if you want to copy it
    • Modified an option name in the config file
    Important note:
    • If you have downloaded a previous version and wish to update, you...
  4. V1.5.0 | Experience Level Update

    Gilles_M
    Update:
    • Added the possibility to modify the player regen amount based on his level
    • Fixed a bug with float regen amount values
    Important note:
    • If you have downloaded a previous version and wish to update, you have to update your config file. If you don't, the plugin will throw errors!
    Copy/paste the following in your config file to update it if needed :
    Code (YAML):

    #If set to true,...
    Kubson_19 likes this.
  5. V1.4.1 | Particle Options Update

    Gilles_M
    Update:
    • Added configurable options for the particle animation (added in the previous update)
    Important note:
    • If you have downloaded a previous version and wish to update, you have to update your config file. If you don't, the plugin will throw errors!
    Copy/paste the following in your config file to update it if needed :
    Code (YAML):
    #If set to true, light green particles will spawn on...
    Kubson_19 likes this.
  6. V1.4.0 | Particles Update

    Gilles_M
    Update:
    • Added the possibility to spawn light green particles around the player when regenerating
    Important note:
    • If you have downloaded a previous version and wish to update, you have to update your config file. If you don't, the plugin will throw errors!
    Copy/paste the following in your config file to update it if needed :
    Code (YAML):
    #If set to true, light green particles will...
  7. V1.3.1 | Bug fix

    Gilles_M
    Update:
    • Fixed a bug where players couldn't regenerate their health after taking fall damage at full health
    Please if you notice any bug, let me know in the discussion section.
  8. V1.3.0 | Per World System Update

    Gilles_M
    Update:
    • Added the possibility to activate the RPG Regen system only in the desired worlds
    Important note:
    • If you have downloaded a previous version and wish to update, you have to update your config file. If you don't, the plugin will throw errors !
    Copy/paste the following in your config file to update it if needed :
    Code (YAML):
    #If set to true, the plugin will only work...
  9. V1.2.0 | 1.12.2 Compatibility Update

    Gilles_M
    Update:
    • Made the plugin compatible with Minecraft 1.12.0+ version, using a deprecated Spigot method to check the player's current world natural regeneration gamerule
    Please if you notice any bug, let me know in the discussion section.
  10. V1.1.0 | Reload Command Update

    Gilles_M
    Update:
    • The command '/rpgregen reload' has been created and now reloads all the changes made in the config without restarting the server
    • The permission rpgregen.reload has been added and is now required to run the command (being an operator bypass the permission)
    Please if you notice any bug, let me know in the discussion section.