RPGItems 3.7.762

The Legacy RPG plugin continues

  1. phoenixlzx
    Tested Minecraft Versions:
    • 1.13
    Source Code:
    https://github.com/NyaaCat/RPGitems-reloaded
    Contributors:
    felixonmars, RecursiveG, cylinChan, Librazy, Taiterio
    This is the plugin continued from the legacy RPGItems2, brought to you by NyaaCat Community.

    Source code published under MIT license, and hosted on GitHub.

    Documents | Discord | All versions

    Installation

    Dependencies
    Select your version of RPGItems: https://github.com/NyaaCat/RPGItems-reloaded/releases

    Upgrade from 3.5

    https://github.com/NyaaCat/RPGItems-reloaded/wiki/RPGItems-3.6-for-1.13.2-Upgrade-Guide

    Problems?

    Kindly submit an issue including your server version and RPGItems version, as well as detailed error log, and description on how to reproduce.
    Qi_Jun, Kiss_me, Roy7885 and 13 others like this.

Recent Reviews

  1. Flako
    Flako
    5/5,
    Version: 3.7.697
    Espero que este listo pronto para la 1.14. ya estoy preparando todo con nuevas ideas :) muchas gracias deberías ponerte deacuerdo con el desarollador de magicpells. ambos Harían cosas espectaculares
  2. Taewoo
    Taewoo
    1/5,
    Version: 3.7.697
    Not working.............................................................................................
  3. Ted_2001
    Ted_2001
    5/5,
    Version: 3.7.697
    Amazing Plugin let you make everything you want to!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  4. molags
    molags
    5/5,
    Version: 3.7.673
    Excellent plugin, it was functional. But it‘s 1.14 time now. Please update to 1.14.
  5. Watamote
    Watamote
    5/5,
    Version: 3.7.664
    Thank you so much for keeping this plugin up to date. It has become the core of everything that happens on our server and we'd be nothing without it. There is just so much potential in item powers, particularly items that have the power to run commands on use. There is almost no limit to what can be done with this plugin when a little imagination is applied.
  6. HerobinreGamer
    HerobinreGamer
    5/5,
    Version: 3.6.569
    I use this plugins for 3 years and until today is verry functional!
    Verry Good Plugins Thanks.
    -gmaestre02
  7. LegionFrost
    LegionFrost
    5/5,
    Version: 3.5.448
    this plugin is amazing i've used this plugin for a long time <3
    lots of features and absolutely free of charge!

    but theres something:
    the tutorial doesnt very clear and hard to understand
    and the plugin help is also messy
    and if you can.. please add page to the help like:
    type /rpgitem help 2 to read page 2
  8. Blake164366
    Blake164366
    3/5,
    Version: 3.5.427
    I have used this plugin many times, Sadly over time you tend to realise that a plugin like this can be made to be easier. Have you ever considered adding a Gui to the plugin?
    1. phoenixlzx
      Author's Response
      I agree plugin should made to be easy to use, however if we want it to be powerful, then 'easy to use' is the cost.

      And we are tend to make it even more powerful and flexible.
  9. zsauer
    zsauer
    5/5,
    Version: 3.5.329
    Great plugin tons of fun to use! Just wondering on a ETA on 1.13 support, no rush just curious when this could be expected! Thankyou for a great plugin!
  10. Vyrgax
    Vyrgax
    5/5,
    Version: 3.5.329
    By far the best plugin for custom items! Everything you need, and even the items update when they are changed in the config. Though, a compatible version for 1.13 would be really great, seeing this great plugin stop at 1.12 would me sad :(
    1. phoenixlzx
      Author's Response
      We are working on this.