SavageFactions // The Ultimate Factions Experience 2.5-RC-6

A new era of Competitive Factions.

  1. ProSavage
    sian2005, hecc_yeah, WarFire and 34 others like this.

Recent Updates

  1. Config Improvement
  2. Worldguard Bypass
  3. Just direct download of jar

Recent Reviews

  1. iSaxxy
    iSaxxy
    1/5,
    Version: 2.5-RC-6
    developer does not respond to me when the download link to his plugin is broken, he also is very rude and insulting to me
    1. ProSavage
      Author's Response
      You're leaking my premium plugins I refuse to help you lol
  2. Valou
    Valou
    5/5,
    Version: 2.5-RC-6
    It's just amazing. I don't know what to say, just THANK YOU. Keep going on this way. Again: thanks! :)
  3. XionioX
    XionioX
    2/5,
    Version: 2.5-RC-6
    There is no Russian translation
    .................
    1. ProSavage
      Author's Response
      am I supposed to just know russian?
  4. NoopyyGaming
    NoopyyGaming
    5/5,
    Version: 2.5-RC-6
    Hey !

    does /f unclaim works too with it or not ?
    BTW this plugin is really great =)
    1. ProSavage
      Author's Response
      too with what?
  5. Lyim
    Lyim
    4/5,
    Version: 2.5-RC-6
    Great plugin, works well wherever you use it! Permission nodes are pretty much identical to other factions plugins, so making the switch to this one is REALLY easy.

    Not a huge fan that other cool features are locked behind a monthly pay-wall. I'm sure we all know there's enough subscription services out there, plugins dont need to be one of them. I would prefer a "pro" version, with a one time charge.
    1. ProSavage
      Author's Response
      So if I just make a one time update for a one time charge then it's fine right?

      I have to work on it everyday. So its a monthly charge and the cost is also lower.
  6. userplays
    userplays
    5/5,
    Version: 2.5-RC-6
    The discord invite link is expired and I need help with this error: Could not pass event PlayerInteractEvent to Factions v1.6.9.5-U0.2.1-RC-1.6.2-RC-2.5-RC-6
    1. ProSavage
      Author's Response
      its updated, thanks for the tip <3
  7. didjee2
    didjee2
    5/5,
    Version: 2.5-RC-6
    All I can say about this plugin right now is: perfect;
    I had an error being spammed in my console: developer instantly fixed it;
    Very friendly Developer aswell.

    The plugin seems to work good (for me at least), and comes with (a bunch) of extra features that other faction plugins do not have.
  8. Horin
    Horin
    2/5,
    Version: 2.5-RC-6
    This plugin is useless right now. Anyone that's not from a Faction can open their chests, put and break blocks, etc, so basically it's not protecting anything.
    I tried getting support from their Discord since 4 days ago and everytime I tell them that nothing it's protected they just ignored me and replied to other people.
    Not only that, this version spams your console every 2-5 seconds.
    The only thing the Staff says is "You're using an outdated version" even tho I told them multiple times I have the lastest, and updated the minute they shared the new version. Still bugged.
    1. ProSavage
      Author's Response
      I tested your issue and it works fine for me
      Try regenerating your conf.json?
  9. Rykpar
    Rykpar
    4/5,
    Version: 2.5-RC-5
    I cannot make myself the faction admin so I cannot set safezones and warzones someone help. Also I am op on the server so I don't know what is wrond
    1. ProSavage
      Author's Response
      Maybe read the wiki instead of reviewing, the wiki has a whole page on this.
      Feel free to delete & join the discord for help.
      I wont spoon feed here.
  10. RobewayneFTW
    RobewayneFTW
    5/5,
    Version: 2.5-RC-5
    Sorry for asking questions, but whenever i go to "territoryBypasssProtectedMaterials"
    Do I put "CREEPER_EGG"? I tried "CREEPEREGG" aswell and the creeper eggs id or "MONSTER_EGG:50" and it still didn't work sorry but please help