SavageFactions // The Ultimate Factions Experience 2.5-RC-6

A new era of Competitive Factions.

  1. userplays
    userplays
    5/5,
    Version: 2.5-RC-6
    The discord invite link is expired and I need help with this error: Could not pass event PlayerInteractEvent to Factions v1.6.9.5-U0.2.1-RC-1.6.2-RC-2.5-RC-6
  2. didjee2
    didjee2
    5/5,
    Version: 2.5-RC-6
    All I can say about this plugin right now is: perfect;
    I had an error being spammed in my console: developer instantly fixed it;
    Very friendly Developer aswell.

    The plugin seems to work good (for me at least), and comes with (a bunch) of extra features that other faction plugins do not have.
  3. Horin
    Horin
    2/5,
    Version: 2.5-RC-6
    This plugin is useless right now. Anyone that's not from a Faction can open their chests, put and break blocks, etc, so basically it's not protecting anything.
    I tried getting support from their Discord since 4 days ago and everytime I tell them that nothing it's protected they just ignored me and replied to other people.
    Not only that, this version spams your console every 2-5 seconds.
    The only thing the Staff says is "You're using an outdated version" even tho I told them multiple times I have the lastest, and updated the minute they shared the new version. Still bugged.
    1. ProSavage
      Author's Response
      I tested your issue and it works fine for me
      Try regenerating your conf.json?
  4. Rykpar
    Rykpar
    4/5,
    Version: 2.5-RC-5
    I cannot make myself the faction admin so I cannot set safezones and warzones someone help. Also I am op on the server so I don't know what is wrond
    1. ProSavage
      Author's Response
      Maybe read the wiki instead of reviewing, the wiki has a whole page on this.
      Feel free to delete & join the discord for help.
      I wont spoon feed here.
  5. RobewayneFTW
    RobewayneFTW
    5/5,
    Version: 2.5-RC-5
    Sorry for asking questions, but whenever i go to "territoryBypasssProtectedMaterials"
    Do I put "CREEPER_EGG"? I tried "CREEPEREGG" aswell and the creeper eggs id or "MONSTER_EGG:50" and it still didn't work sorry but please help
  6. d1m0a1n
    d1m0a1n
    1/5,
    Version: 2.5-RC-4
    This has to be the most consistently buggy plugin I've ever used. Every update that claims to fix bugs from the previous update adds even more. Major functions of the plugin become broken or unusable, and it's extremely frustating, especially when these issues are brought up to the developers and they don't seem to care. There used to be a very useful ticket system on their Discord server, but they have restricted the usage of that to only those who buy their premium plugin, leaving people using this version having to report the bug in their public general support channel, which is usually drowned out by multiple other people reporting bugs, and/or just ignored by the devs.

    When the plugin works, it's pretty good, but I can't say I've had a version yet where everything actually works. There seems to always be something broken. Developers, I'd highly recommend taking a break from adding new content and focus on getting everything to actually work first.
    1. ProSavage
      Author's Response
      I saw your message in support...
      I even told you how to do it.
      You just gotta add creeper egg to the bypass in config. Chill brah.
  7. XionioX
    XionioX
    5/5,
    Version: 2.5-RC-4
    pls, released russian lang.yml
    pls, released russian lang.yml
    pls, released russian lang.yml
  8. Riknesh
    Riknesh
    5/5,
    Version: 2.5-RC-4
    A good fork of the FactionsUUID. But it would be even better if it can be hooked into LWC, letting players to unlock chests once the territory is overclaimed.
  9. ResMc
    ResMc
    5/5,
    Version: 2.5-RC-4
  10. SrLeojaco
    SrLeojaco
    5/5,
    Version: 2.5-RC-4
    Very good plugin. Usefuls features and active development. Like the old factions but with lots on addictions and everyday better.
  11. 10hrWill
    10hrWill
    4/5,
    Version: 2.5-RC-4
    Good plugin, but when I try to claim safezone/warzone it says "you do not have permission to claim this factions land."
    when using /f claim 1 <safezone/warzone> Any help?
  12. hecc_yeah
    hecc_yeah
    4/5,
    Version: 2.5-RC-3
    Nice af fam
    I will say it was a little confusing to figure out the commands at first, but the permissions are layed out nicely for me to set up, being relatively new to hosting a minecraft server.
  13. SrLeojaco
    SrLeojaco
    1/5,
    Version: 2.5-RC-3
    DO NOT USE. DO NOT USE. DO NOT USE. CRITICAL ERRORS INTRODUCED ON CURRENT VERSION FOR SPIGOT RELEASE.

    1. Players can change faction tag even they not have perm
    2. Players can unclaim owned claims even they not have perm
    3. Players can change relation even they not have perm

    I've reported to them since +5 days and they didn't show intereset. Then I added this review looking for this to be fixed.

    Release from 2august also having a critical bug.
    1. ProSavage
      Author's Response
      You didn't even describe your issues correctly.
      All of the commands you mentioned require a permission node.
      Some of them don't require a role, which I added in case that is what you're referring to.
      I cannot really help more than that.

      As for the owned claims I don't know what you're talking about because you did not describe it.
      The /f unclaim command does not care for owner claims or normal claims it blocks it anyways.
  14. KevinMitnik
    KevinMitnik
    3/5,
    Version: 2.5-RC-3
    All in all plugin is pretty good. But this guys can break backward compatibility, your factions will stop work and you will get zero assistance from support
    1. ProSavage
      Author's Response
      you expect to keep data and downgrade? lol
  15. ArifErdoganK
    ArifErdoganK
    3/5,
    Version: 2.5-RC-3
    I agree with what SrLeojaco said .
    1. ProSavage
      Author's Response
      this issue is known simply reset conf.json and it'll work
  16. CLanHao
    CLanHao
    5/5,
    Version: 2.5-RC-2
    Can you make a Chinese configuration?
    I hope the author can share it with Chinese users.
  17. FishyHyper
    FishyHyper
    5/5,
    Version: 2.5-RC-2
    The plugin is great, the support is great. 5/5

    Had a bug using the dev build, the savage team fixed it within hours, it never stops to amaze me the number of updates this plugin gets.

    Every time it gets a new feature or a bug fix amazing work, well done.
  18. ExeoAge
    ExeoAge
    5/5,
    Version: 2.5-RC
    plugin is so good. and the support is great. he helped me in the matter of seconds. will buy a few plugins from him in a few days <3
  19. chebthony
    chebthony
    5/5,
    Version: 2.5-RC
    Plugin works fantastic out of the box, very configurable and ProSavage is a g. Had an issue with an exception and he fixed it within 5 minutes
  20. Biff627
    Biff627
    5/5,
    Version: 2.5-RC
    This plugin has worked out amazingly so far! Just had to figure out how everything works and its been going smoothly ever since!