SecurityVillagers - Protect villagers of your server 2.12.1

A simple plugin to protect villagers and related mobs

  1. AlessioDP
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    Source Code:
    https://github.com/AlessioDP/SecurityVillagers
    Languages Supported:
    French, German, Italian, Polish, Russian, Ukrainian

    [​IMG]
    A simple plugin to protect villagers and related mobs.


    SecurityVillagers is a plugin for Minecraft servers that allows the protection of villagers or any mob like iron golem, illagers, etc... You can choose which players/groups can attack/interact with mobs.
    Read more about SecurityVillagers here!

    [​IMG]

    [​IMG]


    [​IMG]
    Documentation of SecurityVillagers
    Commands reference
    Full permissions list
    Full changelogs
    How to report a bug

    Feel free to translate SecurityVillagers for your language! SecurityVillagers translations.
    You can find the source code here.


    [​IMG]

    • 100% configurable
    • Supports from 1.8.8 to 1.16 MC version
    • Choose how to protect mobs
      • Globally
      • Individually
      • Factions claim
    • Mobs supported
      • Villagers
      • Iron golems
      • Wandering trader and trader llama
      • Illagers
    • Choose who and how protect from all types of damage
    • Prevent interaction/trades/eggs
    • Prevent dispensers damage
    • Change age of mobs
    • Change profession of villagers
    • Change name of mobs
    • External plugins supported:
      • Factions and SavageFactions: Protect mobs inside claims
      • ProtocolLib: Mute annoying villager sounds

    [​IMG]
    • JSON messages supported
    • Async calls (database, commands and more)
    • Statistics system (bStats)

    [​IMG]
    SecurityVillagers uses /sv command. You can change it from config.yml.
    Full list of commands here.

    Before start to use Parties you should setup permissions, you can find the full permissions list here.


    [​IMG]
    Are you looking for help? You can find me on my own Discord server or directly send me a private message on Spigot!

    Join my Discord


    [​IMG]
    SecurityVillagers offers a great documentation to help you to configure it. There you can find everything that you are looking for.
    These are some examples:

    How can I install SecurityVillagers on Spigot/Bukkit?
    Download some translations


    [​IMG]
    [​IMG]

    [​IMG]
    [​IMG]


    Don't write about your problems into the reviews, you can easily contact me via Discord, private message, email or discussion!

Recent Reviews

  1. ASKIT
    ASKIT
    5/5,
    Version: 2.12.0
    Thank you, good plugin. Of course, I was looking for a way to replace trade with villagers, but this will also work)
    1. AlessioDP
      Author's Response
      Thank you :)
  2. misterkeevs
    misterkeevs
    3/5,
    Version: 2.11.0
    Only a few commands are showing up, even when using via console.

    All I see when typing /sv help is a list with help, reload, version, changeage, profession, rename. No other commands work and return the "invalid command" error.
    1. AlessioDP
      Author's Response
      Which command are you trying to execute? I need more information please join the Discord or send me a PM.
      Reviews are not the right place to ask for help
  3. Mokokow
    Mokokow
    5/5,
    Version: 2.5.0
    Excelente, thanks for made this plugin, this plugin work in 1.12.1, but some error if i change age villager. keep spirit!
    thanks again!
    1. AlessioDP
      Author's Response
      Thank you :)
  4. FalconSeeker
    FalconSeeker
    1/5,
    Version: 2.5.0
    Mute villagers isn't working
    ------------------------------------------------------------
    1. AlessioDP
      Author's Response
      Did you enabled ProtocolLib?
  5. hakeem_j
    hakeem_j
    5/5,
    Version: 2.5.0
    real good plugin
    real good plugin
    real good plugin
    real good plugin
    real good plugin
    1. AlessioDP
      Author's Response
      Thank you :)