Fun little plugin. I recommend using command.getName() as opposed to label, that way you can add aliases. Also, it's usually a good idea to put your commands in different classes - it saves alot of headaches when you have lots of commands. Otherwise, you're doing great. I hope you make lots of cool plugins in the future!