SimpleInventories 1.0.6.5

Simple library that will help you with making guis!

  1. ScreamingSandals
    Native Minecraft Version:
    1.13
    Tested Minecraft Versions:
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    Source Code:
    https://github.com/ScreamingSandals/SimpleInventories
    Contributors:
    ScreamingSandals <Misat11, Ceph>
    This library will help you with making inventories and tree guis. Can be used as plugin like ChestCommands or you can bound it as library into your plugin.

    If you have still Java JRE or JDK 8, read spoiler below
    Maybe some of you noticed that we're working on our library for Java 11 because there are lot of new things, new Java APIs and new syntax. But that means that our plugins won't work with Java 8 and with Minecraft lower than 1.12. With some future update we are going to drop Java 8 support (SimpleInventories 1.0.2 still supports Java 8).
    If you are on hosting and don't have Java 11 on it, contact the support of this hosting and ask for an Java 11 option.

    Please use github issue tracker for reporting bugs. Reviews are just for rate this plugin! (And there are still people, that don't understand this)

    Features:
    • Customizable inventory sizes
    • Unlimited nested inventories
    • Paginator
    • Making inventory via YAML/Groovy
    • Groovy callbacks or Java Event handlers
    • Positioning
    • Executing commands
    • Cloning items
    • Easy shop with Groovy (or with YAML and Java plugin)
    • And lots of another features! Just check our wiki: https://github.com/ScreamingSandals/SimpleInventories/wiki
    Known plugins using this as library:
    [​IMG]
    PuRe_Greg and notfoundname like this.

Recent Updates

  1. 1.0.6.5
  2. 1.0.6.1
  3. 1.0.6

Recent Reviews

  1. PuRe_Greg
    PuRe_Greg
    5/5,
    Version: 1.0.2
    I love this Libary. Used it to make LOADS of inventories for my server. please don't kill me. - Greg
    1. ScreamingSandals
      Author's Response
      Thanks for your review XD