TE-FlyEnchant 4.7.1

You can fly if you have this enchant on your item.

  1. vk2gpz
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    NOTE: This a custom enchant module requires TokenEnchant plugin.

    This plugin contains a custom enchantment effect that allows you to fly while you have/wear an item with this enchant.

    This was originally included in TokenEnchant plugin. However, it has been removed from TE itself so that this effect can be used in the different version of TE.

    Demo Video:
    coming...

    Installation:
    Just install TE-FlyEnchant.jar in TokenEnchant/enchants folder. Then you can either "restart the server" or "reload the plugin (not /te reload)". FlyEnchantment will automatically be loaded into TokenEnchant framework.

    Configuration:
    You need to add new entry for "Fly" enchant under the "Potions:" section in your config.yml.

    Code (Text):

    Potions:
      Fly:
        price: 10
        max: 1
        occurrence: always
    #    invalid_in_region:
    #      - nofly
    #    invalid_in_world:
    #      - plotworld
        allowed_items:
          - DIAMOND_BOOTS
        max_speed: 1.0. # value between 0.1 - 1.0. (0.2 is the default fly speed)
        default_speed: 0.05 # if not specified 0.05 will be used.

        #if a player has the following permission node, his fly own't be turned off
        fly_permission_nodes:
          - "essentials.fly"
     
    Donation:
    It would be greatly appreciated for your donation for the provision of support for this plugin.
    [​IMG]
    iTzJonathanxD, zSebaah and Flak like this.

Recent Reviews

  1. chadax019
    chadax019
    5/5,
    Version: 4.6.1
    Very Awesome plugin!!!!!!!
    Thank you for polite correspondence.
    I appreciate very quick response.
  2. ThePurpleHoser
    ThePurpleHoser
    5/5,
    Version: 4.5.0
    works grate with other plugins, which handle their own fly functions (such as Essentials, FactionFly, CMI, etc).