tr-AllowCrackOnline (BungeeCord) 1.1

Allowed users to login on your server

  1. Amosar
    Native Minecraft Version:
    Legacy (< 1.13)
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    Source Code:
    https://gitlab.com/Trafalcraft/tr-AllowCrackOnline
    Tr-AllowCrackOnline is a plugin that allow player without official minecraft version to used your your server with login/mdp
    (This plugin is strongly inspired by AlwaysOnline)

    Use this plugin carefully, i'm not reponsable if it caused bug with your other plugins (The offline UUID are generate randomly)

    I have create this plugin to allow my friends who cant buy Minecraft to play with us and to test my mini-games plugin with multiple account on my online server.

    Feature:
    • Allow user without official minecraft version to connect to your server
    • Allowed user based on mysql database
    • Login/mdp on dedicated server for better security
    • Custom Messages
    Dependency :
    • Mysql database
    • One server dedicated to authentication (the plugin contain his own authentication system but can't block player interaction onto your spigot server)
    Installation :
    1. Setup a mysql Database
    2. Modify your config file with mysql information/name of the auth server and your main server (previously set in BungeeCord config file)
    3. Add the allowed players with /ac add <pseudo>
    How it work :
    • If its a player with normal minecraft version it can connect to your server normally.
    • If a player with cracked version connect to your server
      • If the player have been allowed by an administrator with AllowCrack.usage permission it will be connected to the auth server and need to login to access to the rest of the server.
      • If the player is not allowed, it is just rejected by the server.
    Command:
    • /ac enable - Enable the plugin
    • /ac disable - Disable the plugin.
    • /ac add <pseudo> - Add player allowed to use cracked version.
    • /ac remove <pseudo> - Remove player allowed to use cracked version.
    • /ac list - list all player allowed to use cracked version

    Futur update:
    • Add a bukkit version that don't need BungeeCord (if it's possible)
    • Add a bukkit bridge to avoid the need of a dedicated server for authentication
    • Your suggestions

    If you like my plugin :)
    [​IMG]

Recent Reviews

  1. Malacaritaa
    Malacaritaa
    5/5,
    Version: 1.1
    5 stars, its agreat idea but pls! remove the SQL from obligatory dependencyes
    ----------------
    1. Amosar
      Author's Response
      Thanks for your review.
      I don't have the time to do this know but I think to add this later :)
  2. Buddelbubi
    Buddelbubi
    5/5,
    Version: 1.0
    It works perfect. Thanks
    ________________________________________________________