Ultimate Essentials ✪ [1.8] ✪ Fully Customizable! 2.9

The all-in-one must have resource for any and every server!

  1. 1.9-1.11 Support

    TheJimmyJ57
    Finally implemented 1.9-1.11 Support

    + New Dependencies! Make sure to download the new ones
    + 1.9-1.11 Support
    - /spawner
Return to update list...