VanillaCord 1.2

IP-forwarding support for vanilla

  1. Thinkofdeath
    VanillaCord

    A patcher for vanilla to allow for bungeecord's ip-forwarding

    Usage: java -jar vanillacord.jar <minecraft version>

    The patched jar will be placed in the out sub-folder once completed.

    Currently is known to support 1.7.10 to 1.8 and will most likely work for newer versions too.

    Unlike spigot you do not need to set your server to offline mode. The online-mode setting in server.properties will only be used for commands (e.g. whitelist) when looking up uuid's

    Remember to firewall your server like you do with Spigot. This forces the server into offline mode and allows ip/uuid faking if it isn't correctly secured. http://www.spigotmc.org/wiki/firewall-guide/

    Source: https://github.com/thinkofdeath/vanillacord
    RobinMC, AnhCraft, HAlex and 12 others like this.

Recent Updates

  1. Mojang can't even jar
  2. Online mode(ish)
  3. Branding

Recent Reviews

  1. Obscenity
    Obscenity
    4/5,
    Version: 1.2
    Good but not up-to-date, thankfully someone at the Github page has made a patch for 1.12, but its still not pushed into the master.

    Works on 1.12 if you build it yourself.
  2. SirHawkEye
    SirHawkEye
    1/5,
    Version: 1.2
    Broken on 1.11 and higher, unfortunately. Hopefully there will be another update soon.
  3. TheSmiler
    TheSmiler
    4/5,
    Version: 1.2
    Very good tool, really, allows to extends the possibilities of vanilla servers to create a private mini-game and survival server, in my case.
    However, the it seems to be broken in 1.11!
  4. minecraft7net
    minecraft7net
    5/5,
    Version: 1.2
    Hi,

    any chance to upgrade that great project for 1.10.x ? :) it will be nice to have possibility connect nevest Vanilla version to BungeeCord based MC network
    1. Thinkofdeath
      Author's Response
      Should work without update. Bungeecord however does not support 1.10 yet and without that this wont work
  5. ThunderViper
    ThunderViper
    4/5,
    Version: 1.2
    Great, but please add support for snapshots?
    I setup a 15w31c snapshot server on my network but it says outdated server D: (Which it isnt)
    1. Thinkofdeath
      Author's Response
      This does support snapshots however bungeecord doesn't which is why you are getting that message
  6. Johnanater
    Johnanater
    5/5,
    Version: 1.2
    It's awesome. Thanks!
  7. ThePestsKiller
    ThePestsKiller
    5/5,
    Version: 1.2
    Great for play with my cousin in 1.8
  8. chas13
    chas13
    5/5,
    Version: 1.2
    perfect for 1.8 vanilla maps <3
  9. teozfrank
    teozfrank
    5/5,
    Version: 1.2
    Awesome does exactly what it says on the tin love it!
  10. Willbbz
    Willbbz
    5/5,
    Version: 1.2
    Work great!