"Vehicles" Reloaded 1.3

Have "Vehicles" in minecraft

  1. winterwolf007
    Tested Minecraft Versions:
    • 1.10
    • 1.11
    • 1.14
    Note: Modified from first version (Still works [2019])

    Ever wanted 'vehicles' (sorta) in minecraft? Now you can!

    Commands/Permissions:
    /leathercar car.leather
    /ironplane plane.iron
    /diamondrocket rocket.diamond
    /chainhelicopter helicopter.chain

    Info:
    After typing one of the four commands, you will recieve a certain chestplate. By holding a clock (while wearing one of the four chestplates), you can either:
    • drive in any horizontal direction (leather car)
    • fly in any direction (iron plane)
    • fly upwards (chain helicopter)
    • fly upwards at a high velocity (diamond rocket)
    Dependencies:
    Skript
    (unnecessary) WildSkript (to prevent jumping while utilizing one of the 'vehicles')

    What may come out later:
    More cars, helicopters, planes?
    Shops
    Passengers?

    Potential Questions:
    Why wouldn't I use entities or minecarts?
    Because I'm not good enough to (somehow) make that into reality. This is rather basic skript, but it works. Maybe a texture pack may make it more realistic.

    It's possible to allow a player to become 'disguised' while wearing the 'vehicle', but it is dependent on a certain type of disguise plugin.

    If you need to complain why this skript doesnt use minecarts, etc, just go find another vehicle plugin.
    roger123456v likes this.

Recent Updates

  1. 1.3
  2. 1.2!
  3. 1.1!

Recent Reviews

  1. OskarZyg
    OskarZyg
    3/5,
    Version: 1.3
    It's A Good Idea, however, I could only get the RocketShip To work. I don't know. You should fix it.
  2. ryanrox333
    ryanrox333
    5/5,
    Version: 1.2
    Great Skript! Works on My server just fine. I do this came out 2 years ago but it still works how it is!

    And to people who are whining that its skript.
    Stop bullying people who do skript. People have preferences.
    1. winterwolf007
      Author's Response
      Facts:
      My Java Coding Skills = Abysmal
      My Skript Coding Skills > Abysmal
  3. JordneyEGNL
    JordneyEGNL
    1/5,
    Version: 1.2
    Just buy the real "Vehicles" plugin. Don't make a ripoff plzz.
    And plz code in Java
    1. winterwolf007
      Author's Response
      Emphasis on 'buy'...?
  4. GameFreakBaree
    GameFreakBaree
    1/5,
    Version: 1.2
    bad! Just buy the plugin: Vehicles!
    ----------------------------------------------------
    1. winterwolf007
      Author's Response
      It works. No need to complain, just buy Vehicles.
  5. IHaxMC
    IHaxMC
    3/5,
    Version: 1.2
    1.8? :) s9obhsorgnbsro[bno[iegns[oignswbgswgrbs[9ougbsrobuurpgbup (gotta do 100 characters)
    1. winterwolf007
      Author's Response
      Probably, I've never tested it w/ 1.8 but it will most likely work
  6. Starlex3000
    Starlex3000
    3/5,
    Version: 1.2
    How to install that??????????????????????????????????????????????????????????????????????
    1. winterwolf007
      Author's Response
      It's skript, not a regular plugin. You will have to download the Skript plugin and then place this in the folder designated for skripts
  7. stijnb1234
    stijnb1234
    1/5,
    Version: 1.2
    It isn't working.

    aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa