ViaBackwards 2.3.1

Old Minecraft versions on a newer server. Allow 1.9-1.12 on your 1.10-1.12 server

  1. Matsv
    Tested Minecraft Versions:
    • 1.10
    • 1.11
    • 1.12
    Source Code:
    https://github.com/Matsv/ViaBackwards/
    Contributors:
    Matsv, MylesIsCool
    Don't use reviews to report bugs. Please use the issue tracker, private message or the discussion page!

    Installation:
    This plugin requires to have ViaVersion and Java 8 installed.
    Drag and drop both plugins in your plugin folder, and you are good to go.


    [​IMG]
    You can donate using this button, or you can donate using bitcoins.
    every donation is appreciated!

    [​IMG]
    138xP6V6jakx4dEjcPVbUusPxiZmXVg1v1

    Supported versions:

    [​IMG]

    FAQ:


    Please support 1.8 and lower?
    No, use ViaRewind or ProtocolSupport if you want backwards compatibility for 1.8 and lower.

    Can I use this with BungeeCord?
    Yes, you can also use both ViaBackwards and ViaVersion with BungeeCord.

    How can I report issues and bugs?
    You can report bugs on the GitHub issue tracker. You can also use the Discussion section from the resource or send me a private message.

    Why did you not implement this inside ViaVersion?
    The aim of ViaVersion is to allow a newer Minecraft client on an older Spigot server, by making it inside ViaVersion, people will expect us to also create backwards compatibility in the future. I mainly created this for my own server, I don't know if I'll support backwards compatibility for newer versions in the future.

    Can I donate?
    You can use the donate button from Paypal or bitcoins above to donate to this project :)

    I can't use this plugin because I have Java 7 or lower
    Please update to Java 8 or contact your host to update.


    Donations:

    Vaidas
    theminecoder - Ender Cloud


    API:

    Maven:

    Code (Text):
    <repository>
        <id>viaversion-repo</id>
        <url>https://repo.viaversion.com/</url>
    </repository>

    <dependency>
        <groupId>nl.matsv</groupId>
        <artifactId>viabackwards</artifactId>
         <version>LATEST</version>
    </dependency>

    Links:

Recent Updates

  1. KeepAlive fix
  2. 1.12.2 support
  3. Minecraft 1.12.1 compatibility

Recent Reviews

  1. flynnbettens
    flynnbettens
    5/5,
    Version: 2.3.1
  2. Minhhuy
    Minhhuy
    5/5,
    Version: 2.3.1
    --------------------------------
    Please update for 1.13
    --------------------------------
  3. dmartin11
    dmartin11
    5/5,
    Version: 2.3.1
    Please update for Spigot 1.13
    __________________________________________________________
  4. jonnycp9
    jonnycp9
    5/5,
    Version: 2.3.1
  5. fLowBop
    fLowBop
    5/5,
    Version: 2.3.1
    No problems at all hope you will never stop DEV new versions of it! <3 Thank you!
  6. IHaxMC
    IHaxMC
    5/5,
    Version: 2.3.1
    AMAZING, made my server compatible with many versions. 100% would recommend !
  7. KockaHraje
    KockaHraje
    5/5,
    Version: 2.3.1
    This is best plugin for Backwards please add connection for 1.8.x. Nice developer #ThumbUp.
    1. Matsv
      Author's Response
      Its already supported with another extension: ViaRewind (:
  8. Asura_Prism
    Asura_Prism
    4/5,
    Version: 2.3.1
    Excellent plugin but have error while player play on MC 1.10 and Spigot 1.11 or lower than when place a block slab or stair, it just fixed the velocity! pls fixed player can place block
    1. Matsv
      Author's Response
      Fixed in the latest devbuild
  9. Roadhog360
    Roadhog360
    5/5,
    Version: 2.3.1
    Better than ProtocolSupport if you're looking for 1.9 compatibility, and ViaRewind if you want down to 1.7.
    Nearly flawless. Since I'm giving a good review, might as well report a tiny issue...
    On older versions, trapdoors, slabs, etc seem to always place on the lower half of the blocks, even if you look on the top half.
    1. Matsv
      Author's Response
      Thanks! That issue is known and will hopefully be fixed next version.
  10. NiMain
    NiMain
    5/5,
    Version: 2.3.1
    Is the plugin have dependency with ViaVersion? MyleIsCool please support me!!!!!
    1. Matsv
      Author's Response
      Correct, ViaVersion is required to let this plugin work.