ViaCheckConnection 1.2.8l-SNAPSHOT

Send a message with the name of the version you are connected to the server

  1. x9nico
    Native Minecraft Version:
    Legacy (< 1.13)
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    Source Code:
    https://github.com/x9nico/ViaCheckConnection
    Contributors:
    x9nico
    Languages Supported:
    All languages
    Installation:
    This plugin require ViaVersion : https://www.spigotmc.org/resources/viaversion.19254/
    Install ViaCheckConnection from your plugins folder


    This plugin send a message on the player when a player join and send the name of the version is connected.

    Commands
    /viacheck: Plugin's commands
    /viacheck reload: Reload the config file
    All commands into the plugin, the player must be an OP on the server or have the permission: viacheck.use (Bukkit & BungeeCord)

    FAQ:

    Open-Source ?
    Yes, you can see here : https://github.com/x9nico/ViaCheckConnection/tree/master/ViaCheckConnection

    Screenshots:
    1.8:
    1.8.png

    1.9:
    1.9.png

    1.10:
    1.10.png

    1.11:
    1.11.png

    What versions for messages support ?
    It is support 1.7.x, 1.8.x, 1.9.x, 1.10.x, 1.11.x, 1.12.x, 1.13.x and 1.14.x

    What versions of Java the plugin can support ?
    It is support java 8, 9 and 10.

    Are you do a dev-version and I can download it ?
    Yes, you can see the changelogs on the dev-version at the git : https://github.com/x9nico/ViaCheckConnection/commits/master
    And you can find them when the plugin's version contains the word "SNAPSHOT".

    Where I can report bugs ?
    You can report all issues at the github issues tracker : https://github.com/x9nico/ViaCheckConnection/issues
    Please do not report on a reviews !

    Can I use with BungeeCord ?
    Yes, you can set this plugin on your BungeeCord's plugin folder.

    Can I donate ?
    Yes, if you want do a donation,
    do me a donate by Paypal => https://paypal.me/x9nico ;)

    How can I edit the messages ?
    You can edit the messages with the config.yml in the folder /plugins/ViaCheckConnection/

    I want to contribute to the plugin, how I do ?
    Thanks you for asking it.
    You can contribute to the plugin on GitHub :)

    Contact
    - YouTube: https://youtube.com/c/x9nicoYT/
    - Twitter: https://twitter.com/x9nico
    - SpigotMC: @x9nico
    FLYLAME, TheDevelon, Bolean and 3 others like this.

Recent Updates

  1. 19w11a
  2. 19w05a
  3. 19w02a

Recent Reviews

  1. FLYLAME
    FLYLAME
    5/5,
    Version: 1.2.8g-SNAPSHOT
    Very good plugin! I used this plugin, on my project. Thanks you, for the support)
    1. x9nico
  2. mrfloris
    mrfloris
    5/5,
    Version: 1.2.8d-SNAPSHOT
    Friendly developer, quick updates, keeps up to date with latest snapshots even as soon as ViaVersion has their build out. Friendly support as well. Easy to install, easy to use, and easy to customize.
    1. x9nico
  3. superlsayer
    superlsayer
    1/5,
    Version: 1.2.8d-SNAPSHOT
    Wow, this is just sooo bad !

    320 lines of code for nothing, no reload command on bungee (take less than 30 seconds to add it)

    Error when you use the viacheck command on the console !!! And no permission to use /viacheck (only for op), why ?
    1. x9nico
      Author's Response
      The bungee command will coming soon.
      And I have set for OP only temporairly.
  4. AlbertBlue
    AlbertBlue
    1/5,
    Version: 1.2.8-SNAPSHOT
    your plugin has no 1_9_4 version
    and I can simply use deluxejoin and %viaversion_player_protocol_version% placeholder instead of your plugin, it's even easier to configure by the way
    1. x9nico
      Author's Response
      I don't have any problems in 1.9.4
  5. Peebbong
    Peebbong
    5/5,
    Version: 1.2.7
    Thanks for ViaVersion Addon Plugin! thanks for nice plugin gg! nice author. good job!
    1. x9nico
  6. Nemlin1
    Nemlin1
    5/5,
    Version: 1.2.6-FIX
    A very good plugin and the creator a good person and an incredible support thank you very much.
    1. x9nico
  7. Elguerrero
    Elguerrero
    5/5,
    Version: 1.2.6
    I do not know why people say that the plugin is bad, I'm not a developer yet to know the code or anything but it makes its simple, unique and useful function, and the support is good.
    1. x9nico
  8. Madrid
    Madrid
    3/5,
    Version: 1.2.5q-SNAPSHOT
    I'm giving that a 3/5 because the source code is very poor, the file Is 47.8KB for literally nothing.

    This really needs a rewrite, but on the other half the plugin works fine and the config file is pretty straight forward.
  9. MaxIstderBoss
    MaxIstderBoss
    5/5,
    Version: 1.2.5o-SNAPSHOT
    Hey in advance I want to say mega horny plugin.
    I have an idea and I would wish that you can see with a command with which version the players play
    Best regards
    Max
    1. x9nico
      Author's Response
      Hi, thanks !
      There is a plugin already I think to see the versions of a Player.
  10. superlsayer
    superlsayer
    1/5,
    Version: 1.2.5n-SNAPSHOT
    Very bad plugin, useless plugin, bad source code, i don't understand how you have five starts :o
    1. x9nico
      Author's Response
      It can be useful for some peoples.