ViaRewind Legacy Support 1.4.0

Some additional features for ViaRewind on Spigot servers

  1. Gerrygames
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    Source Code:
    https://github.com/Gerrygames/ViaRewind-Legacy-Support
    Contributors:
    Gerrygames
    Don't use reviews to report bugs. Please use the issue tracker, discussion page or the ViaVersion discord server!

    Information:

    This is an addon to ViaRewind. The features of this plugin will never be never be added to ViaRewind, this is an addon on purpose. ViaRewind is a multiplatform (Spigot, BungeeCord and Sponge) plugin and this plugin is for Spigot only! Adding features to ViaRewind, which do not work on all of the supported platforms would be to confusing in my opinion.

    Installation:

    This plugin is an addon to ViaRewind, so you need to install it first. Installing this plugin requires nothing more than putting it in your plugins folder. After you started your server once you can also disable/enable certain features in the generated config file. This plugin only works on Spigot. If you are using ViaRewind on a Proxy, this plugin will not work.

    Features:

    • The Lily Pad bounding box is being modified. This prevents 1.7.x-1.8.x from glitching if they try to walk over Lily Pads.
    • The Ladder bounding box is being modified. This prevents 1.7.x-1.8.x from glitching if they try to climb Ladders.
    • If a 1.7.x player opens an Enchantment Table this plugin takes Lapis Lazuli from his/her inventory and puts it in the Enchantment Table.
    • 1.7.x-1.8.x can interact with Brewing Stands to add/remove Blaze Powder to/from them.
    • Play block placement and item pickup sounds to 1.7.x-1.8.x players.
    • Velocity is applied during Elytra flight for players below 1.9.
    • Players below 1.8 bounce on Slime Blocks.
    • Makes AreaEffectClouds visible for 1.8.x and lower.
    • More to come!

    Donate:
    [​IMG]

Recent Reviews

  1. _cryptics
    _cryptics
    5/5,
    Version: 1.4.0
    Awsome plugin wich fixes ladder issue. Thanks for delivering this to the community!
  2. Adrixzz123
    Adrixzz123
    5/5,
    Version: 1.4.0
    Finally, thanks so much for you job!--.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.
  3. Xitecraft1
    Xitecraft1
    5/5,
    Version: 1.3.3
    Good plugin! Fixed the sound on our 1.12 Server for 1.8 players.
  4. GronyRalph
    GronyRalph
    3/5,
    Version: 1.3.3
    My sounds still not working on 1.8 when breaking blocks, haven't tried any of the other fixes yet but that was my problem, please hepl, Via is awesome :(
  5. Khosraw
    Khosraw
    5/5,
    Version: 1.3.3
    Works great! Good support and I have not even needed to edit anything as it works out of the box.
  6. MinecraftKid45
    MinecraftKid45
    5/5,
    Version: 1.3.2
    Works Perfect! Did exactly what it said and still works perfectly only 1.16.4 - highly recommended for servers still needing to support legacy versions.
  7. R00t
    R00t
    5/5,
    Version: 1.3.2
    This resource is underrated. This resource fixed a variety of problems that even many large networks seem to face day-to-day. This resource maintains the latest versions, and doesn’t seem to have any compatibility issues, with even the latest versions of Minecraft.
  8. IsabelLomas
    IsabelLomas
    5/5,
    Version: 1.3.2
    Very good work. Loaded it onto my test server that runs ViaRewind because none of my testers could climb ladders :/
  9. Peebbong
    Peebbong
    5/5,
    Version: 1.3.1
    Thanks for Plugin. Always update plugin. Its recommend plugin. Nice author. Thanks!
  10. jonnycp9
    jonnycp9
    5/5,
    Version: 1.3.1
    -------------------------------------------------------------------------------------------------
    Ottimo plugin ha risolto problemi con lilypad per gli utenti con 1.8.x
    my server
    -------------------------------------------------------------------------------------------------