ViaRewind 1.5.2

Allow 1.8.x and 1.7.x on your 1.8-1.12.2 server

  1. Gerrygames
    Native Minecraft Version:
    Legacy (< 1.13)
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    Source Code:
    https://github.com/Gerrygames/ViaRewind
    Contributors:
    Gerrygames
    Don't use reviews to report bugs. Please use the issue tracker, discussion page or the ViaVersion discord server! Also please read the known issues section before asking for help.

    Description:

    This plugin is an addon for ViaVersion (and ViaBackwards). It allows 1.7.x and 1.8.x to connect to your 1.8-1.16.2 server.

    Installation:

    This plugin requires to have ViaVersion and ViaBackwards (for 1.10+ servers). Just put all three plugins in your plugins folder and you are done. Also make sure you have Java 8 installed.

    Supported Versions:
    [​IMG]

    Known issues:
    • Boats and Horses won't work for 1.7.x and 1.8.x clients on 1.9+ servers. This issue can not be fixed without editing the server source code.
    • Although this is not an issue with ViaRewind. If your 1.7.x client crashes, when trying to connect to the server: Check if your clientside view distance is not too high. If you have set your view distance to something higher than 1.7.x allows while playing 1.8 or newer, your 1.7.x client will crash (even if you join singleplayer). Please check this, before you ask for help.

    Addons:

    Support/Discord:
    If you have any questions about any Via* plugin just join the ViaVersion Discord.

    Donate:
    [​IMG]

    Images

    1. 68747470733a2f2f692e696d6775722e636f6d2f794474416746372e706e67.png

Recent Reviews

  1. SubMC
    SubMC
    5/5,
    Version: 1.5.2
    I Have 1.16.4 Server But I Want 1.8.9 PvP How Do i Make It Perfectly??

    Can You Help me??
  2. Nubless
    Nubless
    3/5,
    Version: 1.5.1
    Server works however as soon as I join in 1.8.9 I get kicked out of Badlion client
  3. TheTPQ1H
    TheTPQ1H
    4/5,
    Version: 1.5.0
    Great, but its a shame that it doesn't support 1.4.6-1.6.X like ProtocolSupport does.
  4. SladeHazard
    SladeHazard
    1/5,
    Version: 1.4.5
    Plugin crashes 1.7 players for: Error: java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Byte It is not because of view distance and does not happen if I use protocolsupport. bad plugin for 1.7! please fix
  5. thehydrogen
    thehydrogen
    5/5,
    Version: 1.4.5
    Great plugin, use it on all of my servers. Thank you so much for making this plugin, and especially for making it free.
  6. goldenmaker007
    goldenmaker007
    5/5,
    Version: 1.4.5
    Same question, I run on 1.15 and use Viaversion,Viabackwards and Viarewind and it works but why does it says viaversion Abstraction and Dev on 1.13+ servers, is it like still developing from issues?
  7. dohuuduc
    dohuuduc
    5/5,
    Version: 1.4.5
    thanks very much!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  8. AadamSheikhy
    AadamSheikhy
    4/5,
    Version: 1.4.5
    I installed this on my 1.18 server and I joined on 1.14. It works 100% but I have a question, what is ViaVersionAbstraction? How do i install it?
  9. Reflyansyah
    Reflyansyah
    5/5,
    Version: 1.4.5
    Sangat membantu sekali, keep to update !

    80 caracter LoL, Satay Is A Best Food for Indonesian People
  10. MinecraftKid45
    MinecraftKid45
    5/5,
    Version: 1.4.4
    So basically, it's the best plugin I have ever downloaded and works perfectly. I don't have anything else to say, it's that good.