ViaVersion 4.1.1

Allow newer versions to connect, why lose players after a Minecraft update?

  1. Loiloo
    Loiloo
    5/5,
    Version: 4.1.1
    Great plugin. Please help me, on my server 1.16.5 users don't walk on the deepslate block which comes from 1.18 and can't see it either.
  2. KingTipTop
    KingTipTop
    4/5,
    Version: 4.1.1
    Protocol ids in velocity always fallback


    i write:

    velocity-servers:
    default: 4
    lobby: 754


    then it fall back to:

    velocity-servers:
    default: 4
    lobby: -1
  3. bluejayjensen
    bluejayjensen
    5/5,
    Version: 4.1.1
    One of the best plugins in existence, a must for all servers out there without a doubt.
  4. ThisUserWasFree
    ThisUserWasFree
    5/5,
    Version: 4.1.1
    Works perfectly on all my servers, never had a problem with it, it works every time!
  5. Sohqil
    Sohqil
    5/5,
    Version: 4.1.1
    very good plugin i like it so much lol this is so useful ngl alr bye ............
  6. BoolyStudy
    BoolyStudy
    5/5,
    Version: 4.1.1
    iaversion.bungee.handlers.BungeeServerHandler.channelWrapper" is null
    [08:40:25 ERROR]: at com.viaversion.viaversion.bungee.handlers.BungeeServerHandler.checkServerChange(BungeeServerHandler.java:279)
    [08:40:25 ERROR]: at com.viaversion.viaversion.bungee.handlers.BungeeServerHandler.onServerConnected(BungeeServerHandler.java:112)
    [08:40:25 ERROR]: at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [08:40:25 ERROR]: at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:78)
    [08:40:25 ERROR]: at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    [08:40:25 ERROR]: at java.base/java.lang.reflect.Method.invoke(Method.java:567)
    [08:40:25 ERROR]: at net.md_5.bungee.event.EventHandlerMethod.invoke(Unknown Source)
    [08:40:25 ERROR]: at net.md_5.bungee.event.EventBus.post(Unknown Source)
    [08:40:25 ERROR]: at net.md_5.bungee.api.plugin.PluginManager.callEvent(Unknown Source)
    [08:40:25 ERROR]: at net.md_5.bungee.ServerConnector.handle(Unknown Source)
    [08:40:25 ERROR]: at net.md_5.bungee.protocol.packet.Login.handle(Unknown Source)
    [08:40:25 ERROR]: at net.md_5.bungee.netty.HandlerBoss.channelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.handler.timeout.IdleStateHandler.channelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.handler.codec.MessageToMessageDecoder.channelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.handler.codec.MessageToMessageDecoder.channelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.handler.codec.ByteToMessageDecoder.fireChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.handler.codec.ByteToMessageDecoder.channelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.DefaultChannelPipeline$HeadContext.channelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.DefaultChannelPipeline.fireChannelRead(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.epoll.AbstractEpollStreamChannel$EpollStreamUnsafe.epollInReady(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.epoll.EpollEventLoop.processReady(Unknown Source)
    [08:40:25 ERROR]: at io.netty.channel.epoll.EpollEventLoop.run(Unknown Source)
    [08:40:25 ERROR]: at io.netty.util.concurrent.SingleThreadEventExecutor$4.run(Unknown Source)
    [08:40:25 ERROR]: at io.netty.util.internal.ThreadExecutorMap$2.run(Unknown Source)
    [08:40:25 ERROR]: at java.base/java.lang.Thread.run(Thread.java:883)
  7. kacperleague9
    kacperleague9
    5/5,
    Version: 4.1.0
    Ya should definetly cut off 1.8 support, stop the devil lmao
    I really respect your time and passion!
  8. CamTheCoolKidYT
    CamTheCoolKidYT
    5/5,
    Version: 4.0.1
    I would rate this plugin 500/5 stars. It's amazing, works flawlessly, it's great. I do however wish it did snapshots but I understand why it doesn't, it's just really funny everyone asking me for 1.18 support on my server when it's not even out yet xD
  9. reneschneider
    reneschneider
    2/5,
    Version: 4.0.1
    Es gibt bekannte Crash-Exploits für dieses Plugin, aber sie weigern sich, sie zu beheben, da sie auf 1.8 sind. Schade, daher gibt´s nur einen Stern
    1. FormallyMyles
      Author's Response
      If you're getting this on a 1.8 client with 1.12 server this issue stems from ViaRewind. Unfortunately, older versions of the game do have exploits which if you would like to contribute a fix to ViaRewind (as it's not really actively maintained), everyone would appreciate it. There are too many exploits in older versions to fix all of them, which is a reason why ViaVersion itself warns about this if you run an older server.

      All the maintainers of Via* products are voluntary, the majority of the free time we have is spent on newer versions.
  10. Tree182
    Tree182
    1/5,
    Version: 4.0.1
    There are known crash exploits for this plugin but they refuse to fix them because they are on 1.8. So basically if you are using this plugin to allow 1.8 players then dont expect support, even though this is the whole point of the plugin. Just lazy devs. Its a shame because I used to be a supporter and donator of this plugin but it seems like they just cant be bothered lately. https://github.com/ViaVersion/ViaVersion/issues/2690
    1. FormallyMyles
      Author's Response
      If you're getting this on a 1.8 client with 1.12 server this issue stems from ViaRewind. Unfortunately, older versions of the game do have exploits which if you would like to contribute a fix to ViaRewind (as it's not really actively maintained), everyone would appreciate it. There are too many exploits in older versions to fix all of them, which is a reason why ViaVersion itself warns about this if you run an older server.

      All the maintainers of Via* products are voluntary, the majority of the free time we have is spent on newer versions.
  11. MSDOSabmin
    MSDOSabmin
    5/5,
    Version: 4.0.1
    This plugin is very good,it made many player for my server,I love this plugin,but it may no supprt in 1.17.1 paper,it has some errors,but I believe the Author can update this plugin,I believe you
    1. FormallyMyles
      Author's Response
      For support, see the main page.
  12. Denis-123456789
    Denis-123456789
    5/5,
    Version: 4.0.1
    This plugin is just great! Simple, complex, free! Thanks for your great plugins!
    1. FormallyMyles
      Author's Response
      Thank you :)
  13. MetallicGoat
    MetallicGoat
    5/5,
    Version: 4.0.1
    I am surprised as to how many idiots there are in this review section. Its unfortunate. Great Plugin.
    1. FormallyMyles
      Author's Response
      Thank you for the nice review :)
  14. xiongliu
    xiongliu
    5/5,
    Version: 4.0.1
    Awesome plugin! Never had any issues with it whatsoever. Amazing Developer. keep at it!
    1. FormallyMyles
      Author's Response
      Thank you :)
  15. R00t
    R00t
    5/5,
    Version: 4.0.1
    I’ve made relatively intricate reviews in the past; however, it never gets old when appreciation for someone’s significant efforts and work is praised. This resource is one word: remarkable. The contributors/developers of ViaVersion created something that Minecraft (Mojang) is simply not wanting (and potentially not capable) of doing. Creating a resource that simply requires you to drag and drop a container into your plugins folder for users to join on a newer version is certainly something that maximizes your user base and ensures you can put the time you need into testing newer versions, so you don’t have to be the first to upgrade. Overall, my teams and many others appreciate the effort you put into ensuring supporting newer client versions is not only stable, but also fluid and consistent.

    Continue to do what you do best and continue to enlighten us with your unique approach in supporting newer clients on older servers.
    1. FormallyMyles
      Author's Response
      Thank you for the wonderful review (again!)
  16. MiniMoro
    MiniMoro
    3/5,
    Version: 4.0.1
    The objects when dropped are shown with the image of other objects.
    For example, if I drop a sword it becomes a hoe
    1. FormallyMyles
      Author's Response
      For support, see the main page.
  17. hottrin
    hottrin
    5/5,
    Version: 4.0.1
    I have a 1.8.8 server and I can't join on 1.7.10 :((((((((((((((((((((((((((((((
    1. FormallyMyles
      Author's Response
      For support, see the main page.
  18. ninjagamer64
    ninjagamer64
    5/5,
    Version: 4.0.1
    This is definitely a 6-star plugin. It works perfectly, allowing all players in newer versions to connect.
    Please add a configuration to enable and disable specific versions from connecting, as I only want 1.8 (server version) and latest version players to connect, not everything in between.
    Don’t remove 1.8 support like it says in the console :(((((
    1. FormallyMyles
      Author's Response
      If you need support, see the main config page on how to get it.
  19. TigerPlayz705
    TigerPlayz705
    1/5,
    Version: 4.0.1
    D oesn't work well with Skript , or any plug-ins that work withSkript at all either.
    1. FormallyMyles
      Author's Response
      See main page on how to get support.
  20. minece
    minece
    1/5,
    Version: 4.0.1
    Spam console Viaversion error Airbar :(((((((((((((((((((((((((((((((((((((((((((((((((((
    1. FormallyMyles
      Author's Response
      See the main page on how to get help.