ViaVersion 4.3.1

Allow newer versions to connect, why lose players after a Minecraft update?

  1. Mouton_redstone
    Mouton_redstone
    5/5,
    Version: 4.3.1
    Very useful and incredible, i used it to test my own plugin with different versions at once
  2. kyzzf
    kyzzf
    1/5,
    Version: 4.3.1
    Kicks all 1.19 players when they auto teleports to spawn... Please fix your plugin.
  3. hmjBill
    hmjBill
    5/5,
    Version: 4.3.1
    Very useful plugin, but it will force 1.19 players to be kicked when another plugin executes a command. This compatibility issue needs to be fixed
  4. BeefDev
    BeefDev
    5/5,
    Version: 4.3.1
    Very good and incredible plugin (thats nothing new) , a suggestion to the devs, can you change how BukkitViaInjector compares method return types to find getServerConnection, to use isAssignable inside of =. This would allow devs to use a custom ServerConnection without breaking via version.
  5. fabricio9898
    fabricio9898
    5/5,
    Version: 4.3.1
    1 of the best spigot plugins I highly recommend and their support is very helpful, congratulations and thanks for always updating it with 1.19.
  6. BoolyStudy
    BoolyStudy
    5/5,
    Version: 4.3.1
    for users of viaversion 1.19, it is not yet compatible with minecraft server and other plugins, there is incompatibility, to the point that it kicks everyone after a few seconds or when they interact with commands.
  7. Dominik3311
    Dominik3311
    5/5,
    Version: 4.2.1
  8. ManosSef
    ManosSef
    5/5,
    Version: 4.2.1
    This plugin is absolutely amazing!


    To the two replies below me: WHAT IS WRONG WITH YOU GUYS HE PROMISED HE WILL UPDATE JUST WAIT
  9. raier
    raier
    5/5,
    Version: 4.2.1
    This is a very good plugin I am just asking for a suggestion to add 1.19 support.
  10. BRIHTAKAI
    BRIHTAKAI
    5/5,
    Version: 4.2.1
    add 1.19 suppor please
    i need for server.......
    pleaseeeeeeeeeeeeeeeee
    LP BRIHTAKAI
  11. Jaki64
    Jaki64
    5/5,
    Version: 4.2.1
    Currently very necessary for servers that do not want to update to new versions. ViaVersion is everywhere. :3
  12. Checksum
    Checksum
    5/5,
    Version: 4.2.1
    Simply an outstanding plugin that does exactly what it says with little to no issues at all. I have been using this for years now.

    Never had any problems with it aside from the small compatibility issues that arise from Anti-cheats, which is not even their fault.

    Huge Kudos!
  13. stumper66
    stumper66
    5/5,
    Version: 4.2.1
    This plugin is great for Minecraft plugin developers. Usually you have to test your plugin on different server versions to ensure compatibility. Without ViaVersion you'd have to restart your client to match the server version every time but with this I just leave the latest version client running.
  14. zweaty
    zweaty
    5/5,
    Version: 4.2.1
    Does precisely what it says that it does, a wonderful plugin which is a phenomenal attribute to the Minecraft Administration Community.
  15. SeqSEE
    SeqSEE
    5/5,
    Version: 4.2.1
    Been using this plugin for years. Amazing plugin and can't stress enough the trouble saves not losing players from updates!
  16. Betob89
    Betob89
    5/5,
    Version: 4.1.1
  17. NBCSM
    NBCSM
    5/5,
    Version: 4.1.1
    Thank you.

    Thank you for still maintaining this plugin.
    Thank you for still supporting for Java 8.
    Thank you for still supporting for 1.8.8.

    Have a nice day/night.
    Take care!
  18. KingTipTop
    KingTipTop
    4/5,
    Version: 4.1.1
    Protocol ids in velocity always fallback


    i write:

    velocity-servers:
    default: 4
    lobby: 754


    then it fall back to:

    velocity-servers:
    default: 4
    lobby: -1
  19. bluejayjensen
    bluejayjensen
    5/5,
    Version: 4.1.1
    One of the best plugins in existence, a must for all servers out there without a doubt.
  20. ThisUserWasFree
    ThisUserWasFree
    5/5,
    Version: 4.1.1
    Works perfectly on all my servers, never had a problem with it, it works every time!