WGBlockRestricter Continued 2.1.0

This is a continuation of WorldGuard Block Restricter.

  1. S_Ryan
    Want to restrict the blocks that can be used in a region? Miss the old plugin WorldGuard Block Restricter?

    This is a continuation of the plugin WGBlockRestricter. It has been updated to Java 7, Spigot 1.8.8, WorldEdit 6.1, WorldGuard 6.1, and the latest WGCustomFlags.

    I would like to give credit to the original developer for his original plugin. He wrote it very well. The project has since been abandoned, so I chose to take it over. The original project can be found here: http://dev.bukkit.org/bukkit-plugins/worldguard-block-restricter/

    FOR USAGE OF THE PLUGIN, REFER TO THE ORIGINAL POST.

    What has been done:
    • The last version of the plugins source files have been compiled using updated dependencies.
    Let me know if you find any bugs! I will try to get to them as soon as possible. Thank you. If you need to contact me desperately, add me on Skype (spencer.ryan.c).
    rex1167, Fhocus and aaa8881 like this.

Recent Reviews

  1. BlaseMicrobe
    BlaseMicrobe
    5/5,
    Version: 2.1.0
    Works as intended great plugin thanks really did not want to deal with the blacklist section
  2. pCosminV
    pCosminV
    2/5,
    Version: 2.1.0
    --------------------------------------------------------------------------------------------

    Naah, this don't work, i put the plugin in Plugins Folder, /reload.
    /region flag mine deny-blocks
    deny-blocks don't exist.
  3. matyasvane
    matyasvane
    1/5,
    Version: 2.1.0
    Unknown flag specified...this is bad problem. I cant block items..where is problem? Please repair plugin!
  4. Nutty101
    Nutty101
    5/5,
    Version: 2.1.0
    Glad someone updated it :)
    Many thanks for getting this one over to spigot as it's so much easier to keep track of things and updates.
  5. aaa8881
    aaa8881
    5/5,
    Version: 2.1.0
    I'm glad you updated this plugin. However, I can't make this run in the server with this error, [13:06:07] [Server thread/ERROR]: Could not load 'plugins/WGBlockRestricter.jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: WGCustomFlags
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:219) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at java.lang.Thread.run(Thread.java:745) [?:1.7.0_80]
    Can you take a look at this?
    1. S_Ryan
      Author's Response
      Please post errors in the discussion.
  6. Golicraft
    Golicraft
    5/5,
    Version: 2.1.0
    Work perfectly! Thanks :D
    Say what it says and do what it should do! This helped me allot
    -----------------------------------------------------------------------------------------