WorldGuard Fix 1.7.3

Adds missing 1.9 protections to WorldGuard

  1. Kakifrucht
    Tested Minecraft Versions:
    • 1.9
    • 1.10
    WorldGuard now officially supports Minecraft 1.9+. Use the latest build for all fixes, which makes WorldGuardFix (mostly) obsolete. Harmful lingering potions are not blocked in no PvP areas without this fix, however you can set potion-splash to deny in those regions.

    Old description before WorldGuard 1.9 Update:

    WorldGuard did not yet receive an update for Spigot 1.9+, which causes some issues for servers that have already updated. There is no ETA either, so until then you can use this drop and go plugin. No configuration is required, just drop in /plugins and restart server. You can however toggle any fixes you don't need/want, use /worldguardfix generate (permission node is worldguardfix) to create a default config file if necessary and /wgf reload to reload your changes. It hooks into WorldGuard and is not a standalone plugin.

    Tested with Java 7/8 and Spigot 1.9.2/1.9.4/1.10.2. Hooks into WorldGuard. Ensure that you are using the latest build of WorldGuard. Only compatible with Minecraft 1.9+.

    Currently added:
    • Fixes potion blacklist, blocked potions can no longer be used
      • Will also check lingering potions and tipped arrows (removes effect of arrows)
    • Disables lingering potions in no splash regions
      • Disables areacloud effect in no splash regions aswell
      • Disables negative areacloud effects in no pvp regions
    • Disables fishing hooking of players in no PvP regions
    • Disable frost walker in no build regions
    • Disable chorus fruit tp in no enderpearl regions
    • Disable placement of boats in no build regions (checks vehicle-place flag)
    • Protect lilypads from being destroyed with boats in regions (will remove boat)
    • Disable placement of endercrystals in no build regions
    • Fixes are toggleable via optional config (generate with /worldguardfix generate)
      • World's can be exempt completely
    Please report issues and missing features either on Github or here in the discussion, not in the review section.

    Buy me a coffee? (PayPal)

Recent Reviews

  1. XpcAdam
    XpcAdam
    5/5,
    Version: 1.7.3
    Fixed my worldguard protection problem, this is a great fix would recommend! great
  2. JanSzumotalski
    JanSzumotalski
    1/5,
    Version: 1.7.3
    Dosen't do anything. I must use 100 characters, well................................................
    1. Kakifrucht
      Author's Response
      What kind of functionality did you expect?
      Are you unable to read?
  3. Rotitys_VN
    Rotitys_VN
    4/5,
    Version: 1.7.3
    Member cant open door. I added flag "use" allow but member cant open the door ? Fix it please. Update for 1.11.2 <3
    1. Kakifrucht
      Author's Response
      Update WorldGuard to the latest build, remove WorldGuardFix, everything should be fine. Other than that this plugin does not do anything about doors.
  4. texxxxxx
    texxxxxx
    5/5,
    Version: 1.7.3
    works gr8 for me bro, nice work. ignore the ppl below with the trash ratings, this is a for sure 5star ;)
  5. NuclearBolton
    NuclearBolton
    5/5,
    Version: 1.7.3
    I just made a spawn for my factions server, and downloaded this plugin and it works flawlessly, so far, I am experiencing no bugs. Great Work!
    1. Kakifrucht
      Author's Response
      Thanks, but are you sure that you still need it though? If you update to the latest dev build (linked on top of this page) it shouldn't be necessary anymore.
  6. timothydavidhart
    timothydavidhart
    5/5,
    Version: 1.7.3
    Thanks for the plugin I needed it also @TheQaro why did you rate 1 star.... it seems like you like it
  7. TheQaro
    TheQaro
    1/5,
    Version: 1.7.3
    Nice plugin! I like it . You help me to protect my server! THanks i love you! I went to buy you a coffee but i dont have paypal :c
    1. Kakifrucht
      Author's Response
      No problem, it would be nice if you could correct the star rating to reflect what you wrote ;)
  8. comonier
    comonier
    5/5,
    Version: 1.7.1
    ty for this release, we need to ty you all for your job, you save us and our servers to still following minecraft updates.
  9. SoToasted
    SoToasted
    5/5,
    Version: 1.7.1
    Fixed my chorus issue perfectly you are a saint :D Works well to integrate worldguard. Thank you for making it free!
  10. eepgames
    eepgames
    5/5,
    Version: 1.7
    Absolutely great plugin, had some issues at the start but that was nothing to do with this plugin itself. Thanks so much for adding this for 1.9 users. Keep up the good work!