WorldUpdater 1.2-SNAPSHOT

Update your server world from 1.13 to 1.14 easily

  1. keke142
    Native Minecraft Version:
    1.13
    Tested Minecraft Versions:
    • 1.13
    Source Code:
    https://github.com/jdkeke142/HypercraftWorldUpdater

    The purpose of this simple plugin is to help you to keep your world up to date when switching from one version to another, how? This plugin will simply remove all chunks that do not touch WorldGuard/GriefPrevention regions, so you will need to make a region for each of your players' bases, and run the "convertmyworld <worldName>" command.

    You need to perform the command on Spigot 1.13 Server, and then you can put this world on Spigot 1.14 Server server, please avoid loading chunks in the meantime.


    The chunks deletion can be long, and it could bring your server to time out, to avoid this, put the "timeout-time" key in spigot.yml on a higher value, like 1000.


    You can remove the plugin after conversion.


    This plugin require WorldGuard or/and GriefPrevention and FastAsyncWorldEdit to work properly.


    Attention! Please make a backup of your world before using the command, I will not be responsible for any damage caused on your world if you do not do this!

Recent Reviews

  1. Een_noob
    Een_noob
    5/5,
    Version: 1.2-SNAPSHOT
    ------------------------------------------------
    Still comapatible with 1.15 ??????
    ------------------------------------------------
  2. Een_noob
    Een_noob
    5/5,
    Version: 1.1-SNAPSHOT
    Super good plugin. now I can finally update my worlds without any problems. :)