Premium ᴾᴿᴱᴹᴵᵁᴹ AdvancedMobArena - Slay Mobs for Rewards! [1.16 - 1.18] [Paid]

Discussion in 'Resource Discussion' started by NightExpress, Jul 28, 2016.

  1. Just updated to the latest version and im now getting an error in my log

    Could not load 'plugins\AdvancedMobArena.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
    at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:160) ~[spigot.jar:git-Spigot-b605b31-91c3152]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [spigot.jar:git-Spigot-b605b31-91c3152]
    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.loadPlugins(CraftServer.java:301) [spigot.jar:git-Spigot-b605b31-91c3152]
    at net.minecraft.server.v1_11_R1.DedicatedServer.init(DedicatedServer.java:204) [spigot.jar:git-Spigot-b605b31-91c3152]
    at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:544) [spigot.jar:git-Spigot-b605b31-91c3152]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_91]
    Caused by: java.util.zip.ZipException: invalid CEN header (bad signature)
    at java.util.zip.ZipFile.open(Native Method) ~[?:1.8.0_91]
    at java.util.zip.ZipFile.<init>(Unknown Source) ~[?:1.8.0_91]
    at java.util.zip.ZipFile.<init>(Unknown Source) ~[?:1.8.0_91]
    at java.util.jar.JarFile.<init>(Unknown Source) ~[?:1.8.0_91]
    at java.util.jar.JarFile.<init>(Unknown Source) ~[?:1.8.0_91]
    at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:148) ~[spigot.jar:git-Spigot-b605b31-91c3152]
    ... 5 more
     
  2. Make sure that file is not corrupted. Try to redownload it.
     
  3. Thanks.

    I had replaced a few times but this time I downloaded directly on the server and it worked fine.

     
  4. add scoreboard in lobby
     
  5. Got it to work now!

    But I believe there is some problem when the plugin loads for the first time after server shutdown. If I try to join an arena the first time after server and the plugin have started up with /ama join I get this error message “Error! Arena MobStone is not created”.

    If I then run “reload plugin” it works fine both with /ama join and /ama list.

    Have a nice weekend!

    /Berra
     
  6. Today I have finally found time to try this plugin. I've setup the arena twice, using completely different places/surroundings/size, but no matter what I did today, after match starts I immediately end up back to the lobby with message:

    Code (Text):

    AdvancedMobArena ›› Game on the arena mob1 is ended. Type /ama join mob1 for play!
     
    Arena is setup in a very simple way, following instructions from the video tutorial.

    Does anyone know what is causing this?

    Thanks.

    edit: this happens on a most basic server setup with only AMA plugin installed, or even on a setup with few plugins installed (Vault, Essentials, etc). Number of plugins doesn't seem to make any difference. I looked at PEX debug output while running this and it is not a permission issue either.

    How can the most basic, initial, setup not work?
     
    #1106 X.25, Mar 24, 2017
    Last edited: Mar 24, 2017
  7. Hey ive tried to buy your plugin but u haven't accepted the money so i cant download the plugin. plss i want to use plugin
     
    • Agree Agree x 1
  8. Waiting on an approval for purchase!
     
    • Agree Agree x 1
  9. Please wait, I'll fix this...
     
  10. It doesn't seem to work for me. I set everything, save and finish. but the join sign doesn't work. When I also place the leave sign it stays blank.
    I don't see any errors in the console. I am using spigot 1.11.2
    Please help. Are there any dependancies that I should update?
     
  11. @FooRiNGeST

    With the latest update (I think) I got these bugs:
    1. when you join the mob arena you aren't allowed to quit until the first wave starts. This includes trying to click the redstone in your inventory, using the command, and trying to click a leave sign. None of them work.
    2. If you join the lobby of a mob arena then log out and back in, you'll lose the items that were in your inventory before you joined the mob arena and you get the items that were in your inventory during the time in the lobby (The enderchest and redstone dust)

    Please fix! Thanks!
     
  12. I'm looking at the config, and it offers options for:
    health-regen: true
    food-lock: true - I assume this means we can enable hunger?

    Also, are there any better examples of Waves then the one example you have on the plugins home page?
     
  13. Still waiting to be approved for download..
     
  14. Waiting on an approval for purchase!
     
  15. Make sure that you created signs correctly and that signs is enabled in config.

    Will be fixed!

    Yes.
    Nope. Something is wrong?

    Sorry, guys, I know about this problem, but currently I can't fix it. I'll fix it immediately when I will be at home. It's an issue with my card. Please wait and sorry!
     
    • Like Like x 1
    • Informative Informative x 1

  16. Man ive been waiting like a week now. :/ for this plugin could u plss send me the plugin till u have sorted it [email protected]
     
  17. I can not put these items in the store (by emerald)

    '8':
    Name: '&eFlechas &c+10'
    Lore:
    - '&7- &c+10'
    ID: '262'
    Permission: false
    Cost: 20
    Commands:
    - 'give %p 262 1'
    Slot: 17
    '9':
    Name: '&eLeitinho'
    Lore:
    - '&7- &cLeitinho curador'
    ID: '355'
    Permission: false
    Cost: 50
    Commands:
    - 'give %p 355 1'
    Slot: 17

    erro console:

    28.03 20:33:22 [Server] ERROR Could not pass event InventoryClickEvent to AdvancedMobArena v2.1.6b-beta3 28.03 20:33:22 [Server] INFO org.bukkit.event.EventException 28.03 20:33:22 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:1630) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.PacketPlayInWindowClick.a(SourceFile:31) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.PacketPlayInWindowClick.a(SourceFile:9) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:13) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_121] 28.03 20:33:22 [Server] INFO at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_121] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:715) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_121] 28.03 20:33:22 [Server] INFO Caused by: java.lang.ArrayIndexOutOfBoundsException: 1 28.03 20:33:22 [Server] INFO at ru.Capitalism.AMA.GUI.GUI.getShopCat(GUI.java:245) ~[?:?] 28.03 20:33:22 [Server] INFO at ru.Capitalism.AMA.Listeners.GUIListener.onInvClick(GUIListener.java:116) ~[?:?] 28.03 20:33:22 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_121] 28.03 20:33:22 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_121] 28.03 20:33:22 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_121] 28.03 20:33:22 [Server] INFO at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_121] 28.03 20:33:22 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[Spigot.jar:git-Spigot-db6de12-18fbb24] 28.03 20:33:22 [Server] INFO ... 15 more
     
  18. I tried to purchase this plugin last week, but the transaction status is "unclaimed". Are you still active? This would actually be the 2nd time we purchased it. The first was by an admin that has gone inactive so I can't download updates.
     
  19. me and anther have also done this. the guy replied saying Please wait, I'll fix this...
    and Sorry, guys, I know about this problem, but currently I can't fix it. I'll fix it immediately when I will be at home. It's an issue with my card. Please wait and sorry!
     
  20. Try to download it now. Sorry for waiting.

    Please, use code or something else to paste error logs. I can't see here anything