Premium ᴾᴿᴱᴹᴵᵁᴹ AdvancedMobArena - Slay Mobs for Rewards! [1.16 - 1.18] [Paid]

Discussion in 'Resource Discussion' started by NightExpress, Jul 28, 2016.

  1. Will be added!
     
    • Like Like x 2
  2. I set pets-allowed: true in my arena config file and it keeps saying "mypets are not allowed here!"
     
  3. I'll check it
     
    • Like Like x 1
  4. under waves
    Easy:
    - ZOMBIE:1
    - SKELETON:1
    - SPIDER:1

    is the above how many spawn per spawner placed?
     
  5. No it isn't. It's amount of mobs it total. Spawners will be choosed randomly.
     
  6. Hey, I run a Spigot 1.12 server and I think I have an issue upon start-up when running your plugin. Could you look into this please?
    https://hastebin.com/liwahixawa.css

    Thanks
     
  7. When I try to do /ama wand, it brings up, "An internal error occurred while attempting to perform this command". Any suggestions?
    The same error also occurs when I try to do /ama create
     
  8. Could you show me your arenas config?

    You need to provide an arena name, like this: /ama create MyArena
    P.S. My fail, will be fixed
     
  9. Problem is here:
    Code (Text):
    gui-item-id: §agratz
    Change it to any valid material id, for example 2:0, don't forget to provide a data after material id.
    Then do /ama reload and check if it works.
     
  10. Hey thanks, also this is something pretty small but if I do /ama join rather than /ama join (arena) it gives me an error
    Also, another thing it doesn't allow me to interact with the Kit selector item or the leave item.
    https://hastebin.com/soqizinezu.vbs
     
  11. That is happening because you need to specify an arena to join, ie /ama join YourMapName. I don't think the plugin is currently setup to join a random map when just executing /ama join.

    And for the kit selector or leave item, make sure you are giving the appropriate permission for how you named the kit. For example a kit named starter, you'd need to give the permission ama.kit.starter.
     
  12. Ah, that makes sense. I also have the issue for when I'm within a map I can't interact with the items in my inventory.
    Here's my config if that helps at all: https://hastebin.com/opofaxejik.php
     
  13. When you say that you can't interact with them, i assume that you can receive the kit but can't use the items like drinking a potion or eating piece of food?
     
  14. I believe so, it's just when I try to right click
     
  15. That doesn't really sound like an issue with this plugin, i would double check to see if the permissions are correct and if they are you might start looking into other plugins that you are running that would cause such a thing. :eek:
     
  16. I am doing /ama wand, and I get this error in console:

    Code (Text):
    21.07 18:48:35 [Server] ERROR null
    21.07 18:48:35 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'ama' in plugin AdvancedMobArena v2.6.0
    21.07 18:48:35 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:645) ~[spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.PlayerConnection.handleCommand(PlayerConnection.java:1385) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.PlayerConnection.a(PlayerConnection.java:1220) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_112]
    21.07 18:48:35 [Server] INFO at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_112]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.SystemUtils.a(SourceFile:46) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:747) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:405) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:678) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:576) [spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112]
    21.07 18:48:35 [Server] INFO Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
    21.07 18:48:35 [Server] INFO at ru.Capitalism.AMA.Commands.WandCommand.perform(WandCommand.java:19) ~[?:?]
    21.07 18:48:35 [Server] INFO at ru.Capitalism.AMA.Commands.CommandBase.execute(CommandBase.java:26) ~[?:?]
    21.07 18:48:35 [Server] INFO at ru.Capitalism.AMA.Commands.MainCommand.onCommand(MainCommand.java:48) ~[?:?]
    21.07 18:48:35 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot-1.12.jar:git-Spigot-99c2a37-9a82fa7]
    21.07 18:48:35 [Server] INFO ... 15 more
     
  17. Try /ama wand <arena>
     
  18. Does this plugin support Multiverse-Core as well?
     
  19. Could we get a status on the progress of the update?