Spigot ☄️ RHSignItem - /sign your items! [1.12.2 - 1.17.1] 1.17_R8

Freies Signieren von Items / Freely sign your items ☄️ Inspired by GrieferGames.net

  1. Hallo X0R3,
    kannst du dieses Plugin auch unter Java 11 kompilieren, bzw. ist es unter Java 11 ausführbar?

    Viele Grüße
     
  2. Alles Gut ist auch net lebensnotwendig
     
  3. Hi, das Kompilieren auf Java 11 ist hier nicht notwendig. ;) Ich nutze im Plugin keinerlei neue Funktionen oder Abstrakte und somit ist das Plugin ab Java 8 Problemlos ausführbar ^^ Hab das beides ausführlich getestet.
    Ich habe in Java 15 gecoded, weil ab der kommenden 1.17 auch Paper auf Java 8 nicht mehr läuft und ich alles up2date haben will. Also alles kein Problem. Du kannst das Plugin ungehindert nutzen, Hauptsache ab Java 8.
     
    • Friendly Friendly x 1
  4. @Cantibra Wenn dir das Plugin gefällt, dann lass doch ein positives Review da :)
     
  5. X0R3 updated RHSignItem - /sign your items! [1.12.2 - 1.16.5] with a new update entry:

    1.15.0-1.16_R19 - Item Rename Update

    Read the rest of this update entry...
     
  6. X0R3 updated RHSignItem - /sign your items! [1.12.2 - 1.16.5] with a new update entry:

    1.15.1-1.16_R20 - Config Message Hotfix

    Read the rest of this update entry...
     
  7. X0R3 updated ☄️ RHSignItem - /sign your items! [1.12.2 - 1.17.0] with a new update entry:

    1.17_R1 - The 1.17 Support Update

    Read the rest of this update entry...
     
  8. If the map is signed, can the map be cloned?
    I want to let player to sign the map and only that player can clone the map.
     
  9. Hello there!

    Unfortunately, this is impossible as the NBT-based signature is stored on the item. Since the item is literally cloned or doubled at the cartography table, the NBT tags of the original item are also adopted. Here is a picture for clarification:

    rhsignitem_answer1.png

    I am sorry, that I can't give you a solution on your request, but I hope that you will use my plugin in the future :)

    Have a nice day,

    X0R3
     
  10. Hallo.
    Ich versuche das Plugin auf der 1.16.5 zu nutzen, aber es lädt leider nicht.
    Hier der Log-ausschnitt, von dem ich denke das da der Grund steht: https://pastebin.com/YsmguUcx
     
  11. Hallo!

    Ja das liegt daran, dass ich das Plugin bislang schon mit Java 15 entwickelt habe. Und da du natürlich Java 8 nutzt kannst du das Plugin nicht laden.

    Allerdings hatte ich es tatsächlich vergessen zurück auf Java 8 zu schreiben und natürlich bist du jetzt dadurch auf meinen Fehler aufmerksam geworden.

    Ich habe nun ein Update gepushed; das musst du herunterladen und auf den Server packen. Dann geht es: https://www.spigotmc.org/resources/...tems-1-12-2-1-17-0.66509/update?update=412015

    Ich hoffe ich konnte helfen! :)
     
  12. Anscheinend kann man keine Netherit sachen Signieren, könntest du das bitte korrigieren?
     
  13. player can to delete other player sign
     
  14. Huhu, danke für die Info. Auch wenn ich mir sicher bin, dass es funktioniert, weil ich lange an dem 1.17 Patch gearbeitet habe. Ich gehe davon aus, dass du auch die neues Version vom Plugin nutzt? :)

    Ich schau mir das heute Abend mal an. Und falls es auch bei mir zu einem Fehler führt, dann poste ich sofort einen Hotfix!

    LG,
    X0R3