Premium ⚔ Heroes Premium ⚔ 10% OFF BEST RPG PLUGIN EVER [Paid]

Discussion in 'Resource Discussion' started by Kainzo, Jun 13, 2016.

  1. is it a Chinese version? or any Lang file?
     
  2. how to edit the attributes languages?
     
  3. See the FAQ if you haven't already, there isn't a language file (though many skill messages can be changed in their own config). It is a eventual intended feature but requires a lot of rewriting since it wasn't considered in the beginning.

    I can't remember entirely, but I don't think Potion Skills are fully functional at the moment. It was working, but I haven't had the time to look into them again and make sure the issues are resolved.
     
    • Like Like x 1
  4. all the components available in the files, I had no problems translating. I don't ask to translate everything, but to be able to have for example a language.yml file where we can spend our time to translate
     
  5. Having an issue with the arcaneblast skill in the arcane and dreadful pack:
    [00:07:50 ERROR]: Could not pass event PlayerInteractEvent to Heroes v1.9.3-SNAPSHOT-b1096e2
    java.lang.IllegalArgumentException: data should be class java.lang.Void got class java.lang.Integer
    at org.bukkit.craftbukkit.v1_15_R1.CraftWorld.spawnParticle(CraftWorld.java:2397) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.craftbukkit.v1_15_R1.CraftWorld.spawnParticle(CraftWorld.java:2392) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.craftbukkit.v1_15_R1.CraftWorld.spawnParticle(CraftWorld.java:2381) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.craftbukkit.v1_15_R1.CraftWorld.spawnParticle(CraftWorld.java:2361) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.craftbukkit.v1_15_R1.CraftWorld.spawnParticle(CraftWorld.java:2341) ~[patched_1.15.2.jar:git-Paper-143]
    at com.herocraftonline.heroes.characters.skill.pack5.SkillArcaneblast.use(SkillArcaneblast.java:62) ~[?:?]
    at com.herocraftonline.heroes.characters.skill.TargettedSkill.use(TargettedSkill.java:170) ~[?:?]
    at com.herocraftonline.heroes.characters.skill.ActiveSkill.execute(ActiveSkill.java:403) ~[?:?]
    at com.herocraftonline.heroes.command.CommandHandler.dispatchSkill(CommandHandler.java:107) ~[?:?]
    at com.herocraftonline.heroes.listeners.HPlayerListener.onPlayerInteract(HPlayerListener.java:289) ~[?:?]
    at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor429.execute(Unknown Source) ~[?:?]
    at org.bukkit.plugin.EventExecutor.lambda$create$1(EventExecutor.java:69) ~[patched_1.15.2.jar:git-Paper-143]
    at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:80) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:559) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.craftbukkit.v1_15_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:463) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.craftbukkit.v1_15_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:430) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.craftbukkit.v1_15_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:426) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.PlayerConnection.a(PlayerConnection.java:1421) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.PacketPlayInBlockPlace.a(PacketPlayInBlockPlace.java:5) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:23) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.TickTask.run(SourceFile:18) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.executeTask(IAsyncTaskHandler.java:136) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.executeNext(IAsyncTaskHandler.java:109) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.MinecraftServer.ba(MinecraftServer.java:1038) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.MinecraftServer.executeNext(MinecraftServer.java:1031) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.awaitTasks(IAsyncTaskHandler.java:119) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.MinecraftServer.sleepForTick(MinecraftServer.java:1015) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:938) ~[patched_1.15.2.jar:git-Paper-143]
    at java.lang.Thread.run(Thread.java:834) [?:?]
     
  6. How does someone go about registering a new skills pack as a premium pack? I'd be interested in producing a bunch.
     
  7. Hi there, first off I want to say I love the plugin. But I need a little help, I'm not sure if I did something wrong but Mobs do no damage? Same for falling and everything else. Is there a fix to this?
     
  8. Hello i have some problems with heroes, i'm using MMOitems, RPGinventory:
    So i have a scoreboard where the health is 100 / 100, i created a simple item that add 100 health and when i equip it i died.
    I reappear instantly without black screen and my character is leaning to the left, trembling.
    Also my health is point is now 100 / 20
    And if i get killed by a monster, i reappear with a health line with 0 / 100

    Someone can help me ?
     
  9. I have bought a plugin off spigot before so yes i think so becuse it happed on my plugin i boght so if it updates you wont have to pay again
     
  10. enterih

    Patron

    is there a way to translate in German ?
     
  11. Is this the right place to look for support? I'm having problems with the leveling and EXP system. It's all stuck at one level and player's can't lose or gain EXP no matter what methods I try.
     
  12. The premium skills will work in 1.15.2 servers?
     
  13. I need assistance, as this plugin makes the arrow shoot weirdly weak, making it drop shortly after shot, with this bug you can shoot an arrow maximum 10 blocks ahead of you, no more. I tried removing all the plugins except heroes, protocol lib, vault and the problem still persisted, so I'm pretty sure it's from heroes
     
  14. Have you tried moving the skills and see if this still happens? chances are there's a skill causing this.
     
  15. They have actually solved it since and posted on discord instead:
    Its a passive skill amongst the default pack, though of course it can be tweaked in the config.
     
  16. Hey, I bought the plugin earlier today but never received a download. Is this abnormal, or should I just wait for it to be processed? Thanks
     
    • Like Like x 1
  17. Is there a public API to depend on for plugins? I'm aware of the nexus repository mentioned on the description page, but that doesn't even contain the latest legacy release.