Spigot ⚜ CommandProtect ⚜ Protect your commands as you want safely |100% Customizable [1.7.x-1.15.x] 1.5.3

Securely protect the commands of your Spigot server

  1. @ZMarcGamerPvP
    i have this error, how can i fix this ?

    Code (YAML):
    29.09 04:07:33 [Server] INFO Enabling CommandProtect v1.4.5
    29.09 04:07:33 [Server] INFO =+=+=+=+=+=+=+=+=+=+=+= CommandProtect =+=+=+=+=+=+=+=+=+=+=+=
    29.09 04:07:33 [Server] INFO Checking for updates...
    29.09 04:07:33 [Server] ERROR The updater could not contact dev.bukkit.org for updating.
    29.09 04:07:33 [Server] ERROR If you have not recently modified your configuration and this is the first time you are seeing this message, the site may be experiencing temporary downtime.
    29.09 04:07:33 [Server] ERROR null
    29.09 04:07:33 [Server] INFO java.net.SocketException
    : Connection reset
    29.09 04:07:33 [Server] INFO     at java.net.SocketInputStream.read(SocketInputStream.java:210) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at java.net.SocketInputStream.read(SocketInputStream.java:141) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.security.ssl.InputRecord.readFully(InputRecord.java:465) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.security.ssl.InputRecord.read(InputRecord.java:503) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:983) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1385) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1413) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1397) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1564) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1492) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:263) ~[?:1.8.0_181]
    29.09 04:07:33 [Server] INFO     at ru.tehkode.libs.net.gravitydevelopment.updater.Updater.read(Updater.java:643) [PermissionsEx-1.23.4.jar:?]
    29.09 04:07:33 [Server] INFO     at ru.tehkode.libs.net.gravitydevelopment.updater.Updater.runUpdater(Updater.java:718) [PermissionsEx-1.23.4.jar:?]
    29.09 04:07:33 [Server] INFO     at ru.tehkode.libs.net.gravitydevelopment.updater.Updater.access$100(Updater.java:36) [PermissionsEx-1.23.4.jar:?]
    29.09 04:07:33 [Server] INFO     at ru.tehkode.libs.net.gravitydevelopment.updater.Updater$UpdateRunnable.run(Updater.java:713) [PermissionsEx-1.23.4.jar:?]
    29.09 04:07:33 [Server] INFO     at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181]
    29.09 04:07:33 [Server] INFO Couldn't check for updates, don't you have internet connection?
     
    • Like Like x 1
  2. This is not an error, simply the update checker could not connect at that moment. If it keeps coming, let me know. Thanks for reporting!
     
  3. ZMarcGamerPvP updated ⚜ CommandProtect ⚜ Protect your commands as you want safely |100% Customizable [1.8.x-1.13.x] with a new update entry:

    Update 22/11/2018

    Read the rest of this update entry...
     
  4. Besides that this isn't a BungeeCord plugin, it actually blocks BungeeCord commands like "/alert"?
    I think this is the plugin I was searching for, but why you don't open-source it? Since it's free, people can see the source-code and contribute to it, or just see your awesome coding-abilities (this is just my opinion).
    Thank you. :)
     
  5. Hello @Gilbert98

    At the moment I only work with Spigot, later that works with BungeeCord.
    I've been thinking about the open source code, but the plugin is not finished yet, when it is, I may upload it to GitHub.

    Thanks you very much for your opinion!
     
    #25 ZMarcGamerPvP, Nov 23, 2018
    Last edited: Nov 23, 2018
  6. Then this will be my plugin to protect commands, thank you so much for your friendly reply.
     
    • Like Like x 1
  7. Thanks you so much;)
     
    • Like Like x 1
  8. You have paused the development of this plugin?
    Does the Console can execute blocked commands without logging in?
    Switching topic, I have fresh suggestions!
    Add a logout command: "/cmdprotect logout".
     
  9. Hello! The console does not have to log in, it always has all the permissions. That idea is good, I keep it. So far I have stopped, but later I will continue with the plugin.

    A greeting!
     
  10. ZMarcGamerPvP updated ⚜ CommandProtect ⚜ Protect your commands as you want safely |100% Customizable [1.8.x-1.13.x] with a new update entry:

    Update 07/07/2019

    Read the rest of this update entry...
     
  11. add permissions blocker

    protectedpermissions:
    - -worldedit.*

    I see a similar function in Restricted Creative plugin

    [​IMG]
     
  12. My plugin protects only commands, the permissions do not make sense to protect them since you can add or remove them in the confg.yml of your permissions plugin. Thanks for your idea!
     
  13. if griefers and cheaters evade the registration plugin, if it makes sense.
    so they need a second password to use the world edit commands, for example
    admins do not remove and add permissions every time they leave and join the server
    worldedit has more than 120 commands, it is better to directly block the permission (-worldedit.*), instead of putting a list of commands

    Sorry for any mistakes. English is not my native language
     
    #34 Therufianx, Jul 26, 2019
    Last edited: Jul 26, 2019
  14. It is assumed that if a griffer tries to enter it does not have to know the CommandProtect password, since that is what my plugin is about
     
  15. I do not fully understand your idea, if they will pass the authme through a bungeecord bug they would still need the CommandProtect password to be able to execute the blocked commands. I still do not see the meaning of blocking permissions, since in itself it could not be due to the fact that if you do not have the permissions directly you cannot use it
     
  16. If someone enters with an account with permissions, the griffer has a different IP address, CommandProtect recognizes it and asks you to log in again to be able to execute the blocked commands. You can directly block the first word of a command so you cannot execute the rest of them that have to do with the same plugin
     
  17. Of course you can block double "//"
    Example: - //wand
     
  18. ZMarcGamerPvP updated ⚜ CommandProtect ⚜ Protect your commands as you want safely |100% Customizable [1.8.x-1.14.x] with a new update entry:

    Update 2/11/2019

    Read the rest of this update entry...