Spigot ✅ TheAPI ✅ 1.7.10 - Latest 8.0

Create plugins easier than before!

  1. TheDevTec updated TheAPI [1.7.10 up to 1.15.2] with a new update entry:

    GUIs required update!

    Read the rest of this update entry...
     
  2. TheDevTec updated TheAPI [1.7.10 up to 1.16.1] with a new update entry:

    Support 1.16

    Read the rest of this update entry...
     
  3. Server version 1.16.1
    Paper Spigot
    Code (Text):
    [02:24:41] [User Authenticator #7/WARN]: java.lang.NullPointerException
    [02:24:41] [User Authenticator #7/WARN]:     at me.DevTec.Bans.PunishmentAPI.getIP(PunishmentAPI.java:24)
    [02:24:41] [User Authenticator #7/WARN]:     at me.DevTec.Bans.PlayerBanList.getStartTime(PlayerBanList.java:100)
    [02:24:41] [User Authenticator #7/WARN]:     at me.DevTec.Bans.PlayerBanList.getExpire(PlayerBanList.java:53)
    [02:24:41] [User Authenticator #7/WARN]:     at me.DevTec.Bans.PlayerBanList.isIPBanned(PlayerBanList.java:31)
    [02:24:41] [User Authenticator #7/WARN]:     at me.DevTec.Utils.Events.onLogin(Events.java:424)
    [02:24:41] [User Authenticator #7/WARN]:     at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor318.execute(Unknown Source)
    [02:24:41] [User Authenticator #7/WARN]:     at org.bukkit.plugin.EventExecutor.lambda$create$1(EventExecutor.java:69)
    [02:24:41] [User Authenticator #7/WARN]:     at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:76)
    [02:24:41] [User Authenticator #7/WARN]:     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70)
    [02:24:41] [User Authenticator #7/WARN]:     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:607)
    [02:24:41] [User Authenticator #7/WARN]:     at net.minecraft.server.v1_16_R1.LoginListener$LoginHandler.fireEvents(LoginListener.java:311)
    [02:24:41] [User Authenticator #7/WARN]:     at net.minecraft.server.v1_16_R1.LoginListener$2.run(LoginListener.java:251)
    [02:24:41] [User Authenticator #7/WARN]:     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    [02:24:41] [User Authenticator #7/WARN]:     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    [02:24:41] [User Authenticator #7/WARN]:     at java.lang.Thread.run(Thread.java:748)
    [02:24:41] [User Authenticator #7/INFO]: TheAPI: End of error.
     
  4. TheDevTec updated ✅ TheAPI ✅ 1.7.10 - Latest with a new update entry:

    Fixed bugs

    Read the rest of this update entry...
     
  5. Bon plugin !
     
    • Friendly Friendly x 1
  6. TheDevTec updated ✅ TheAPI ✅ 1.7.10 - Latest with a new update entry:

    Fixed bugs, New config options

    Read the rest of this update entry...
     
  7. TheDevTec updated ✅ TheAPI ✅ 1.7.10 - Latest with a new update entry:

    Performance update

    Read the rest of this update entry...
     
  8. TheDevTec updated ✅ TheAPI ✅ 1.7.10 - Latest with a new update entry:

    Fixed bugs

    Read the rest of this update entry...
     
  9. TheDevTec updated ✅ TheAPI ✅ 1.7.10 - Latest with a new update entry:

    Release!

    Read the rest of this update entry...
     
  10. TheDevTec updated ✅ TheAPI ✅ 1.7.10 - Latest with a new update entry:

    Renamed package names, New sockets

    Read the rest of this update entry...
     
  11. TheDevTec updated ✅ TheAPI ✅ 1.7.10 - Latest with a new update entry:

    Removed Unsorted<Map/List/Set>, Fixed bugs and optimized

    Read the rest of this update entry...