Spigot ✨ Amazing Fishing ✨ 1.7.10 - Latest 4.4

Make fishing more interesting !

  1. You have to install TheAPI plugin -> https://www.spigotmc.org/resources/theapi.72679/
     
  2. Love it, but for some reason the fish I recieve have no tags or anything, so name and custommodeldata doesn't work
     
  3. Custom model data is only for 1.14+, You can disable vanilla fish in /fish setting
     
  4. Works fine, thank you for the help, unfortunately, I was struck with some other issues.
    Sometimes the GUI wouldn't close, or saving what biomes the fish can be caught in would glitch the in game gui, and sometimes no fish at all.

    I played around with the plugin some more, and i'm very happy with the way its turned out so far though, aside from the few bugs, very good. all I would suggest is a way to make the drops focus on one thing only, or maybe chances of catching, instead of splitting it between cod and the other fish, and treasure.
     
  5. Hello SplatMe, please all bugs report to our discord or to the github. Discord: https://discord.gg/z4kK66g, github: https://github.com/Straiker123/AmazingFishing
     
  6. Hi,

    Is there way to integrate this really nice plugin with WorldGuard to we can make just in some regions your plugin work. That will be very nice, because, a lot of players will come like on one lake to fish, and that will be like tournament in real life! :)
     
    • Agree Agree x 2
  7. ERROR Corrupt error when creating fish type Salmon, biome DEEP_OCEAN
    08.01 17:45:37 [Server] ERROR Corrupt error when creating fish type TropicalFish, biome DEEP_OCEAN
    08.01 17:45:40 [Server] ERROR Corrupt error when creating fish type Cod, biome DEEP_OCEAN
     
  8. Why not to display this message on the console every time a player is fishing?


    ERROR Corrupt error when creating fish type Salmon, biome DEEP_OCEAN
    09.01 17:50:46 [Server] ERROR Corrupt error when creating fish type Salmon, biome DEEP_OCEAN
    09.01 17:50:58 [Server] ERROR Corrupt error when creating fish type TropicalFish, biome DEEP_OCEAN
    09.01 17:51:00 [Server] INFO CONSOLE issued server command: /list
    09.01 17:51:00 [Server] INFO Há 1 de um máximo de 80 jogadores online.
    09.01 17:51:00 [Server] INFO Gra-Mestre: ፠Grã-Mestre፠Pinguim24
    09.01 17:51:05 [Server] ERROR Corrupt error when creating fish type Salmon, biome DEEP_OCEAN
    09.01 17:51:15 [Server] ERROR Corrupt error when creating fish type Salmon, biome DEEP_OCEAN
    09.01 17:51:23 [Server] ERROR Corrupt error when creating fish type Cod, biome DEEP_OCEAN
    09.01 17:51:28 [Server] ERROR Corrupt error when creating fish type Cod, biome DEEP_OCEAN
    09.01 17:51:32 [Server] INFO CONSOLE issued server command: /list
    09.01 17:51:32 [Server] INFO Há 1 de um máximo de 80 jogadores online.
    09.01 17:51:32 [Server] INFO Gra-Mestre: ፠Grã-Mestre፠Pinguim24
    09.01 17:51:35 [Server] ERROR Corrupt error when creating fish type Cod, biome DEEP_OCEAN
    09.01 17:51:43 [Server] ERROR Corrupt error when creating fish type Cod, biome DEEP_OCEAN
    09.01 17:51:50 [Server] ERROR Corrupt error when creating fish type Salmon, biome DEEP_OCEAN
    09.01 17:51:57 [Multicraft] Auto-saving world...
    09.01 17:51:57 [Server] INFO Saving is already turned on
    09.01 17:51:57 [Server] INFO Saving the game (this may take a moment!)
    09.01 17:51:58 [Server] INFO Saved the game
    09.01 17:52:03 [Server] ERROR Corrupt error when creating fish type Salmon, biome DEEP_OCEAN
    09.01 17:52:03 [Server] INFO CONSOLE issued server command: /list
    09.01 17:52:03 [Server] INFO Há 1 de um máximo de 80 jogadores online.
    09.01 17:52:03 [Server] INFO Gra-Mestre: ፠Grã-Mestre፠Pinguim24
    09.01 17:52:07 [Server] ERROR Corrupt error when creating fish type Cod, biome DEEP_OCEAN
    09.01 17:52:14 [Server] ERROR Corrupt error when creating fish type Cod, biome DEEP_OCEAN
     
  9. unable to modify the configuration file, it will be restored automatically after overloading...
     
    • Agree Agree x 1
  10. Fixed in new update (v3.2)
     
  11. @straiker123 Plugin isn't loading last version. And yes I have last version of TheAPI
    Code (Text):
    [22:56:05 ERROR]: Could not load 'plugins\AmazingFishing.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
            at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:159) ~[patched_1.14.4.jar:git-Paper-243]
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:142) ~[patched_1.14.4.jar:git-Paper-243]
            at org.bukkit.craftbukkit.v1_14_R1.CraftServer.loadPlugins(CraftServer.java:355) ~[patched_1.14.4.jar:git-Paper-243]
            at net.minecraft.server.v1_14_R1.DedicatedServer.init(DedicatedServer.java:226) ~[patched_1.14.4.jar:git-Paper-243]
            at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:876) ~[patched_1.14.4.jar:git-Paper-243]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_241]
    Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
            ... 6 more
     
  12. I'm very sorry, I have defiled your plug-in, I will continue to translate it into Chinese! I will translate it into the most perfect! I'm very sorry for you!
     
    • Like Like x 1
  13. Hello? when update 1.16?