Spigot 【TerrainHousing】- Build your beautiful house, access everywhere! 1.1.0-SNAPSHOT

Build houses like how it works in Trove!

  1. Hey, love this plugin concept, its EXACTLY what im looking for. I know the plugin says its for 1.13. However, i tried it on 1.15.1, and it seems to be functioning at least a little lol. Im having some issues if you could rectify them. Im not sure IF you intended the plugin to be used on 1.15.1, however il post my issues anyway.

    I followed the instructions on how to set up a plot, and i think it worked, the sign gives the correct info, the skull worked, and everything, except i had a plane of grass blocks included in the schematic, which it seems to place in the bottom left corner of said plot whenever i activate it, which is off center of where i set the origin of the plot and the schematic. The sign then tells me its about to expire INSTANTLY after i click it and the plane of grass forms, then i lose ownership of the plot, but the grass persists afterward. I also get this error - https://pastebin.com/ma9NURnT

    All in all i love this plugin so far, and id be happy to give it a 5 star rating if you could solve my issues :p
     
  2. This issue is expected I think. And the reason that cause this issue is currently you have no way to store your player facing while copying schematic, it has to be stored in an additional player data file. Also everytime you create a new Housing, your schematic should be placed in specified facing, but the plugin doesn't know which direction your schematic are facing coz it doesnt save such data.

    1.PNG
    Imagine you are copying a rectangular schematic while standing at yellow point, the schematic is saved vertically.
    And if you want to paste it in 90degrees rotated, you have to rotate 90degrees of the whole schematic, but the plugin doesnt know the facing of your original schematic, so it cant be placed properly.

    In square case, you are copying the schematic in red point, if you are pasting it in yellow point, the schematic will be placed as it shows below.
    If you are not getting the correct corner, lets say the blue point, your schematic will be placed in aqua square, which is your case, it overrides the sign you've placed, and the plugin can't find the sign you've set up before, so the error you've stated occurs.

    To avoid these issues,
    - Build your schematic in square
    - Make sure you are copying & pasting the schematic at the same corner (origin)

    I know this plugin might be a little buggy coz it is just a fun project for me. But you are welcomed to post a yt video that demonstrates the problem, it helps me understand better :D
     
  3. I fixed the grass plane being placed in the corner (thanks :D) but its still removing my ownership of the plot as soon as iv claimed it. Heres a vid.

    There are no more errors however.

     
    #4 Zarkiel, Jan 15, 2020
    Last edited: Jan 15, 2020
  4. /th Idle <Id> <Ticks>: Set how long will Housing edit session expires.
    Did you use this command?
     
  5. I did not, thanks, il test it out
     
  6. I used the command and the sign says "Idle: 0.00" and then changes back to being able to be claimed, i tried setting to 300 and 1000
     
  7. Can you send me your config file and a vid that demonstrates the problem?
     
  8. the vid i sent before is the exact same problem lol
     
  9. https://pastebin.com/830RBqDY this is my config, "2" is the one im using for testing, i made 1 and 2 to test how it works swapping between the two, but i havent had success getting just number 2 to work yet, so i havent bothered setting up "1" properly.
     
  10. I would recommend you setup both of them properly before testing them coz the plugin needs minimum point and maximum point to work.
     
  11. The "1" is working with a proper countdown now, but places in the wrong spot, im going to remake just 1 plot from scratch with fresh configs and fresh schematics now that i know how it works, and try to get it working fully.
     
  12. I made a vid to showcase the issue. Its going to take a while to upload to youtube.
     

  13. Here the vid showcasing what im doing.

    EDIT: I placed the origin in the wrong place and didnt actually set the schematic properly in the vid, but i fixed it annd its still placing stuff outside my zone and also breaking my border i set up (which isnt part of the min/max) And also anything i place while its owned by me doesnt show up whhen i claim it again.
     
    #14 Zarkiel, Jan 15, 2020
    Last edited: Jan 15, 2020
  14. Just wondering if you could make it a bit simpler to use, maybe make it use a worldedit selection to make the min/max instead, and have it auto set the origin to the center of the selection.
     
  15. 1.JPG
    Try to move your origin from blue to red.
    Also you should delete old data, coz i csee that your sign got instantly updated right after you type command and place it down. I assume that the plugin is triggering another Housing's event, which cause the misplace of the schematic.
    And I didn't see where you copy the schematic but I assume that you made it corrently, just make sure that
    Housing minimum = //pos1
    Housing maximum = //pos2, the plugin doesn't help you select worldedit's region
    Housing origin = where you are standing while //copy, if you don't know you have to //copy before you //schem save, just a reminder if you've already done it.
     
  16. I moved my origin from blue to red, but then the same thing happened on the other side, i made it center and then it fixed, but then i had a random grass block plane appear over near red...
     
  17. I think i just found the issue. My FAWE is not copying blocks lol, it just says "0 blocks copied" i think there in lies the issue.
     
    • Useful Useful x 1
  18. This plugin is EXTREMELY infuriating now. I got the schematic working, the plot claimed, then unclaimed after its duration and everything was fine. Then i click it to claim again, and it deletes a whole quarter of the plot (including the sign and skull) and places the schematic in the bottom right corner, i just CANT understand this plugin.

    Feels like any progress im making is just blown up right in my face. Could YOU make a video, showing how its done, precisely because clearly im doing something majorly wrong, but it feels like im following the instructions perfectly.
     
  19. Would you mind giving me your server ip via pm and I help you setting this up?