1.11 Is Now The Default Version

Discussion in 'News and Announcements' started by md_5, Nov 30, 2016.

Thread Status:
Not open for further replies.
  1. md_5

    Administrator Developer

    As of this post, Minecraft 1.11 is now the default version generated by BuildTools. This means that bug reports will only be accepted from a recent 1.11 version and our community volunteers will be preferring to give help and support for this version.

    The promotion of the 1.11 series to default, two weeks after release, means that we feel it is more stable / feature complete than any prior 1.10.x series release, and that your server would be at a disadvantage in terms of features/bugs/exploits by running an older version. You should also keep in mind that the majority of plugins requiring updates will have been updated by now (if only in development builds), and if not then it may be time to begin investigating alternatives as it is likely they will never do so.

    We have kept the outdated startup delay for the time for the time being, but reduced its impact even further. If you do not update your server after 10 days, there will be a 15 second delay and warning message before it starts. Remember that new versions are released daily, and getting them is as simple as re-running BuildTools and replacing your server jar.

    ~Spigot Team
    @Spigot_MC
     
    • Like x 41
    • Winner x 9
    • Agree x 2
    • Optimistic x 2
    • Friendly x 1
  2. First

    Edit: 1.11 is bae, thanks for the rapid updates :) Keep up the great work! XenoGet has been on fire updating builds.

    [​IMG]
     
    • Like Like x 2
  3. Nice, good to see 1.11 as default!
     
  4. loving the solid updates @md_5 keep doing amazing work!
    (As well as all the others who helped create and bugtest 1.11)
    I will definitely be putting 1.11 as a priority in creating public plugins now.
     
    • Friendly Friendly x 2
    • Like Like x 1
  5. Legoman99573

    Supporter

    For those who haven't updated since day 1, Don't start crying about a feature being buggy when its fixed already. And good luck with the 15 second delay :p
     
    • Friendly Friendly x 1
  6. Awesome! Keep up the great work!
     
  7. Is the snowball bug fixed yet :(

    Where snowballs hit someone but the hit doesn't register
     
  8. Yeahh Finally 1.11 is default. I hope everyone updates !
     
  9. Inkzzz

    Resource Staff

    Splendid! We appreciate all the hard work by the Spigot development team. Will hopefully make a donation over the Christmas period.
     
  10. Thx, SpigotMC. Keep up the good work. I will update my server later. Has the InventoryClickEvent bug bean fixed yet?
     
  11. Sweet, tnx for the update. We are going to upgrade to 1.11 very soon.
     
  12. MiniDigger

    Supporter

    Did you report it on jira? else it can't get fixed ;)
     
    • Informative Informative x 1
  13. Thanks for all the bug fixes! :D
     
  14. Fab work guys :D already updated over here !
     
  15. @md_5 Why are you trying to force people to use a newer server version when the new gameversions arent what people want to play?
     
    • Funny Funny x 4
    • Agree Agree x 2
  16. Last I checked, versions 1.9+ had roughly the same amount of servers as 1.8-. The newest version, while not everyone's favorite, is still very much needed, and makes the most sense to be default. Personally, It would be confusing if the default version was not the newest.
     
    • Agree Agree x 1
  17. MiniDigger

    Supporter

    nobody is forcing anyone here. he just stopped supporting old versions, like everybody would do.
    if he would force you, he would disableing the ability to build old versions in BuildTools or some stupid shit like that.
    but since spigot and bukkit are open source, you are welcome to maintain your own fork of those outdated versions where you try to fix all the bugs and exploits those old versions have ;)
     
    • Agree Agree x 5
    • Like Like x 1
Thread Status:
Not open for further replies.

Share This Page