Solved 1.11 spigot plugin doesnt start

Discussion in 'Spigot Plugin Development' started by Loxo, Jun 10, 2018.

  1. Hello everyone,
    Im trying to code my own spigot plugin for 1.11 but whenever I want to try some features it doesnt seem to work.
    A crash report pops up in the console:

    [11:39:01 ERROR]: Could not load 'plugins\Lobby.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: name is not defined
    at org.bukkit.plugin.PluginDescriptionFile.loadMap(PluginDescriptionFile.java:898) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101]
    at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:232) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101]
    at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:157) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [spigot_server.jar:git-Spigot-f950f8e-0a81101]
    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.loadPlugins(CraftServer.java:300) [spigot_server.jar:git-Spigot-f950f8e-0a81101]
    at net.minecraft.server.v1_11_R1.DedicatedServer.init(DedicatedServer.java:204) [spigot_server.jar:git-Spigot-f950f8e-0a81101]
    at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:542) [spigot_server.jar:git-Spigot-f950f8e-0a81101]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_25]
    Caused by: java.lang.NullPointerException
    at org.bukkit.plugin.PluginDescriptionFile.loadMap(PluginDescriptionFile.java:891) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101]
    ... 7 more

    ---------------------------

    Can someone tell me if something is missing?
     
  2. Benz56

    Moderator Supporter

    Your plugin.yml is invalid. Missing a name.
     
    • Agree Agree x 1
  3. read the error
     
  4. It's a problem with your plugin.yml
     
  5. Thank you^^ I made a spelling mistake.
     
  6. Try this:

    in your plugin.yml:

    Code (Text):

    name: YourPluginName
    main: yourpackage.yourmainclass
    author: you
    version: 1.0
     
    Edit: if this helps, like this post :)
     
    • Optimistic Optimistic x 2
  7. Benz56

    Moderator Supporter

    The thread is already marked as solved and has been for over an hour. Stop fishing for likes.

    @Loxo could you lock the thread?