1.13 REBUILD old PLUGINS

Discussion in 'Spigot Plugin Development' started by relucaXIV, Jul 16, 2018.

  1. With the 1.13 I need a plugin made for 1.12 no longer support by dev, so I want to decompile it and recopile with the new bukkit api changing some issues I can meet, someone can help me? Thanks
     
  2. UPDATE: I think the plugin is OpenSource
     
  3. If you link the plugin source-code here, we can tell you how to do so.
     
  4. Provide the github link, the decompiled olugin or the plugin name
     
  5. some help? Thanks very much
     
  6. Two classes needs to be changed.Looking into it tommorow evening.
     
    #7 ysl3000, Jul 16, 2018
    Last edited: Jul 16, 2018
    • Friendly Friendly x 2
    • Like Like x 1
  7. Ok thaks very much. This what I need to do:
    - Import it on eclipse without errors (I need only the essentials code for do work the plugin on bukkit)
    - Edit the code
    - Compile the code
     
    • Friendly Friendly x 1
  8. I was able to compile it for 1.12 with gradle updating the ropisotories. Then I added 1.13 repositories, but the code gave me errors into only a class, so I changed a lot the code but when I try to create a world with the plugin, it gives me a runtime error. The reason is simple: in the spigot jar a class changed. Here's a page where I posted all the informations about that error. I hope you could help me, I have no idea about how to fix yet T_T
    https://www.spigotmc.org/threads/problem-with-updating-plugin-to-1-13.329996/
     

  9. Try these two classes.
    https://github.com/Craftstuebchen/I.../com/github/hoqhuuep/islandcraft/nms/v1_13_R1



    Change the field to d

    Edit:

    I see the problem. Worldprovider is Not hold in the class anymore.
     
    #11 ysl3000, Jul 22, 2018
    Last edited: Jul 22, 2018
  10. Yes it's right and I tried with "d" but the variable d is a boolean
     
  11. Would you have any idea about how to avoid that problem?
     
  12. Hello.
    I tried to compile the entire project provided by
    ysl3000 fork (here:
    https://github.com/Craftstuebchen/I.../com/github/hoqhuuep/islandcraft/nms/v1_13_R1)

    It compiles without errors, but when I load the plugin in my craftbukkit-1.13-pre7 server I see this message:
    "Islandcraft does not currently support this CraftBukkit version"
    And if I look in IslandCraft-NMS-v1_13_R1 folder I see that the build folder in which you should find the compiled jar is missing. So it seems that IslandCraft-NMS-v1_13_R1 has not been compiled by gradle. (Which is what ysl3000 writes in his github repository "It compiles but doesn't drop a finished jar". )
     
  13. Hello again, I spent some time trying to resolve the problem, and I think I succeded. I can compile Islandcraft plugin linked to craftbukkit-1.13.
    I loaded the plugin in my server and it seems working without errors.
    You can try yourself, I have just created a git repository here:
    https://github.com/harrier77/IslandCraftFork
    You can download the compiled jar to direct test it from here:
    https://github.com/harrier77/Island...IslandCraft-developNew-BukkitLatest-1.0.8.jar
    Let me know if it really works because I am not sure of it.
     
    • Like Like x 1

  14. Added a patchfile to fix the field not found exception.


    EDIT: See https://github.com/harrier77/IslandCraftFork/pull/1
     

    Attached Files:

    #16 ysl3000, Jul 23, 2018
    Last edited: Jul 23, 2018
  15. Ok, I merged your patch in my code. I tried again in my windows server and I entered with a 1.13 mc client, everything seems working, Let me know if you test it.
     
  16. I need to force start the server with Java 8. At the moment I'm searching the dependencies so that the plugin can run on Java 9+.
     
  17. Even the current version of the plugin boots and runs without errors. The issues are in the worlds themselves, where it seems they are not generated as they used to be. So, the plugin probably isn't working correctly.
     
  18. I'm working for him on this and I'm able to install the custom World chunk manager and everything but when I join the world the game crash giving a client npe