[1.14.4] which plugins+(versions) would i need to make 1.8-1.15 join?

Discussion in 'Spigot Plugin Help' started by ENCOM, Feb 18, 2020.

  1. hi there,
    i was working on that for hours but i couldn't make it work.
    i installed:

    ViaVersion-2.2.3
    ViaRewind-1.4.5
    ProtocolSupport.jar

    my clients with 1.8 - 1.15 can join, but client crashes after 1-2min due to a Rendering Block Entity error..(light blue screen for 3 sec, then client crash, server seems unaffected)
    Code (Text):
    The game crashed whilst rendering block entity
    Error: com.google.common.util.concurrent.UncheckedExecutionException: java.lang.NullPointerException
    is it even possible to make it work using 1.14.4?
    would be more than thankful if someone could provide me with the correct plugins and the right version, kinda desperate now:/
     
    #1 ENCOM, Feb 18, 2020
    Last edited: Feb 18, 2020
  2. Just use ViaVersion and ProtocolSupport (development build), as the one on spigot I believe only supports 1.12.2 server.
    https://protocol.support/

    ViaRewind is useless since you're using 1.14.4.
    Better yet, why not just use 1.15.2 instead?
     
    #2 ExtremeSpirit, Feb 18, 2020
    Last edited: Feb 18, 2020
    • Friendly Friendly x 1
  3. It's better to use 1.15.2 - it's more optimized and, you know, it's up-to-date. Also with 1.15.2 (for now) you don't need ViaVerision - just ProtocolSupport.
     
    • Agree Agree x 1
    • Friendly Friendly x 1
  4. ProtocolSupport can, apparently, cause issues with other plugins. It may be best to just not use it and accept that players can only join if they’re playing 1.15.2. You’ll lose out on players on older clients being able to connect, but your server will be more stable, and you won’t experience serious issues with certain plugins. :coffee:
     
    • Friendly Friendly x 1
  5. I ran 1.15.2 with ProtocolSupport and it made my server unplayable. 3 GB of RAM tied up, and the server rolled over and died with 7 players on.

    Switched to the above Via* builds and it ran fine with 20+ players.
     
    • Friendly Friendly x 1
  6. ViaVersion does the opposite to ProtocolSupport, though. ProtocolSupport lets older clients connect to a server running a newer version, whereas ViaVersion lets newer clients connect to a server running an older version. And ViaBackwards and ViaRewind are both outdated. :coffee:

    Edit: They’re not outdated. The latest builds are on the Jenkins pages.
     
    #7 DeleteMetaInf, Feb 18, 2020
    Last edited: Feb 18, 2020
    • Friendly Friendly x 1
  7. I had all three plugins, and they're not outdated. They were updated 3 days ago. I ran 20+ 1.8.9 players on my 1.15.2 server with Via* (see the '*'?), but ProtocolSupport killed my server by hogging 3 GB of RAM.
     
    • Friendly Friendly x 1
  8. im left with some plugins i need to update but this takes quite some time since i have used nms for some stuff, sadly..

    i think i stay with 1.14.4 for a while since i can just use viaVersion to let also 1.15 connect:)

    thanks a lot Bobcat00, i downloaded these but i still get the same error as mentioned in my original post, im quite not sure what might be causing it but when i see these performance issues due to all these plugins, i stay with just viaVersion which adds just 1.15 support:)

    maybe i gonna test it again with friends so maybe it crashes just at my end but i expect the same issue, anyways, thanks a lot for all your help in this thread!
    i gonna close it in the next days, maybe someone has a solution for my issue:)
    Wishing you all a nice friday!:)
     
  9. Consider the possibility that there's an error in your world.
     
    • Informative Informative x 2
  10. You don't need all three.
     
  11. Yes, he does. 1.14 server with 1.8 - 1.15 clients.