1.15 crash without error

Discussion in 'Spigot Help' started by drszxn, Dec 15, 2019.

  1. I am using 1.15 and got rid of all the plugins to test.
    The machine is only running Minecraft Server and ran 1.14.4 fine.

    [16:58:23] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-047b6f8-61d4b09 (MC: 1.15) (Implementing API version 1.15-R0.1-SNAPSHOT)



    I time out...
    • [01:59:00] [Server thread/INFO]: drszxn lost connection: Timed out

    ...TPS is 20, then the server literally just stops without a java crash...
    • [21:06:32] [Thread-27/INFO]: You are running the latest version[m
    • [21:06:40] [Thread-2/INFO]: Stopping server
    -------
    • [16:58:10] [Server thread/INFO]: Done (25.255s)! For help, type "help"
    • >version
    • [16:58:23] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-047b6f8-61d4b09 (MC: 1.15) (Implementing API version 1.15-R0.1-SNAPSHOT)
    • [16:58:23] [Server thread/INFO]: Checking version, please wait...
    • [16:58:24] [Thread-12/INFO]: You are 1 version(s) behind
    • [17:14:25] [Thread-2/INFO]: Stopping server



    I was thinking it had something to do with the map as that, i think, is the only thing that makes the server not "pure new". I was using the same map in 1.14.4 and there were a few blocks missing here and there after loading it in 1.15.


    If I let the server run without logging in, there is usually no issue (except in the above second example) and it just runs fine.


    Any ideas?
     
  2. Code (Text):
    [16:58:24] [Thread-12/INFO]: You are 1 version(s) behind
     
  3. Yeah, I thought that too.


    These are less than 24 hours apart 12/14 & 12/15:
    • [Thread-27/INFO]: You are running the latest version
    • [Thread-12/INFO]: You are 1 version(s) behind


    Once I investigated Jenkins, I saw there is no new version, and this is the last:
    Build #447 (Dec 10, 2019 11:33:06 PM)
     
  4. I believe you need to re-run build tools to build the latest jar :)
     
    • Agree Agree x 1
  5. Wanna try to help me with the buildtools compile error? lol

    First time ever I have ran across a buildtools error. Don't see the error on the wiki:

    pastebin here
     
  6. I would suggest to re-download everything and try again?
    The buildtools are working fine for me and so is 1.15.

    If that doesn't work can you show us the script you're executing to run the buildtools?
     
  7. In my best Valley Girl Voice: md_5 was all like "it's your system" and I was all like "no way!" then was all like "no, you're right"

    damn it lol. My linux box is having a stupid permissions issue.



    I withdraw all the things. Ignore me
     
    • Funny Funny x 1
  8. Lol. Anyway I hope you'll get it to work! :) If you do you can mark this thread as solved.