1.15 map error with 1.14

Discussion in 'Spigot Help' started by xSadik, Jan 24, 2020.

  1. Hi! i'm new to this and I need help.
    Recently I tried to "downgrade" my 1.15.1 spigot server to 1.14.4 version. Everything went well except the map, when I entered the server the map was completely "new" and all the buildings and changes were removed and this appeared on console:
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [98, -186]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [99, -186]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [100, -186]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [101, -186]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [102, -186]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [103, -186]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [104, -186]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [105, -186]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null
    23.01 19:22:52 [Server] Server thread/ERROR Couldn't load chunk [105, -185]
    23.01 19:22:52 [Server] INFO java.lang.ArrayIndexOutOfBoundsException: null

    such a message but much longer...
    What can I do to be able to play in 1.14.4 without losing the progress of the map? (I have map backup)

    thanks and sorry about my english :c
     
  2. md_5

    Administrator Developer

    Delete the map and restore the backup
     
  3. I tried that but it didn't work :(
     
  4. md_5

    Administrator Developer

    Is the backup from 1.14 lol
     
  5. Since the dawn of MC I don't think you have ever been able to downgrade a "map" (world).
    Im pretty sure the client even has a giant warning regarding this when you open an old world in a newer game version (ie: open a 1.14.4 world on a 1.15.2 client = big warning)

    If you have a backup of your world from 1.14.x, use that world.
    If you do not have a backup, you're SOL.

    On top of all that, 1.14.x has been one of the worst MC updates in a very very long time. Why in the world would you want to downgrade from 1.15.x -> 1.14.x?
     
    • Winner Winner x 2
  6. Optic_Fusion1

    Resource Staff

    I SHALL FIND OUT!
    I have waaay to many MC versions that i do literally nothing with :p

    Edit: Only seeing migration of old data, nothing about downgrading
     
    #6 Optic_Fusion1, Jan 24, 2020
    Last edited: Jan 24, 2020