1.15 PEX Issue

Discussion in 'Spigot Help' started by MROVOXO_, Feb 19, 2020.

Thread Status:
Not open for further replies.
  1. Good morning,

    Firstly I apologize if this has been answered somewhere, but I've researched for hours and cannot find anything. My server recently has started the problem of denying my admin access to pex even though I have the permissions.* node in the group file, as well as his own personal permissions. Of course pex works just fine with the '*' permission (access to everything without /op) but I'm not exactly looking to give out full access just yet. I've gone through all my pex groups to make sure there's no negative permission anywhere, which there isn't, so I'm just about out of ideas here.

    Is there any solution anyone can think of, or maybe something I'm missing here?


    https://pastebin.com/vDwkPF0z
     
  2. Pex is not supported in 1.15.2. Use luckperms. Pex has been unsupported for years now. https://luckperms.net/
     
    • Agree Agree x 1
    • Optimistic Optimistic x 1
    • Optimistic Optimistic x 1
  3. PEX2 is in early dev. and and alpha builds are available for testing. PEX1 is unsupported and has been for years.
     
    • Agree Agree x 1
  4. Don't be lazy !
    You should NOT give the 'admin' the '*' permission, you should give the group the permissions that are required.
    Many of these permissions can be given by an accumulation of the previous groups.

    Even 'admin's should not be given permission to some of the server features !
    That is very dangerous !
     
    • Agree Agree x 2
  5. I completely agree. As I said, I'm not looking to give my admins every permission, hence why I'm only trying to give permissions.* but they get the message "You do not have permission!" when they try any pex commands.
     
  6. Wow that's pretty cool. I was not aware of PEX still being worked on. Still, the last official release was released on Jan 31, 2016. I would at least wait until they make a pre-release to use it. Either way, Luckperms is so much better in so many ways and will probably be worked on until the Minecraft community dies. Pex is pretty confusing to set up for beginners and isn't worth the confusion.

    To answer your question, (sorry for not doing so before) you need to give them the permission to give them access to any command - '*'
    You need to include the ''
    I understand that's not quite what you want. you just want to let them use pex commands.

    I'm not quite sure why yours didn't work, but I the one I tried does work.

    Here's what I used https://pastebin.com/raw/E5agTUwq

    Hope that helps!
     
  7. Unfortunately pex is all I've used up until now, but I guess it's time to switch, unless this "Pex2" works out. Did you try that in pex or luckperms?
     
  8. I used that in PEX. Luckperms doesn't use the same format nor a permissions.yml file.
     
  9. If you want admin or OPs to use all of pex commands, you should set allowOps: true on the PermissionsEx configuration file [config.yml] and then make sure to restart the server after setting that to true, DO NOT USE /pex reload for that, you required to restart the server.
     
Thread Status:
Not open for further replies.