1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

[1.6] Bungeecord cannot connect to remote server after upgrade

Discussion in 'Bugs & Feature Requests' started by Shicking, Jul 3, 2013.

  1. Hello,
    I have updated to bungeecord #561 and spigot #981.
    I am running Bungeecord and 5 spigot servers on one machine, and one spigot server on another machine. Both machines are on the same internal network.
    Everything was working in 1.5.2
    After the upgrade to 1.6, every time I try to connect to the new server it gives this error -
    Code (Text):
    Could not connect to default server, please try again later: io.netty.channel.ConnectTimeoutException
    In the log of the remote spigot server there is this line each time I try to go there:
    Code (Text):
    [INFO] /172.23.70.130:33673 lost connection
    None of the configs were changed after upgrade. Is there some parameter which is different in 1.6?
    Bungeecord config - http://pastebin.com/vytNt20y
    Server.properties - http://pastebin.com/gPQz6uKw
    Spigot.yml - http://pastebin.com/ZVJpniKR
    Bukkit.yml - http://pastebin.com/fMrgK0UU

    I checked, netstat shows that spigot on the remote machine is listening on the right port.
    Also, I checked with nc -z <IP> <PORT>; echo $?
    The right port (in this case 25572) is open.
    Still, Bungeecord does not sees the server. What else can be wrong?

    Any help will be appreciated! Thank you in advance
     
    #1 Shicking, Jul 3, 2013
    Last edited: Jul 3, 2013
  2. Stupid questions first
    Are the servers on the same IP space?? (172.23.70.x)
    Are they on the same switch?? (same vlan)

    Also are you port forwarding to the 72.8.141.121 ip, if you are then change your BungeeConfig to 0.0.0.0:25565.
     

  3. The servers are on the same IP space.
    The servers are on the same switch
    Also, I can telnet from my bungee machine to my right ip + port on the remote machine.
    I am not sure about the portforwarding - 72.8.141.121 is my ddos protected ip and it works through a GRE tunnel.

    The whole setup was perfectly working with 1.5.2, nothing changed in the network configuration or in the server configuration. I've been trying to solve this for more than a day now :(
     
  4. Is that IP assigned on that machine directly??

    If not changing the Bungee config.yml to use 0.0.0.0:25565 should do the trick.
     
  5. No, it is not assigned on the machine directly.
    I am not sure I understand what 0.0.0.0:25565 means. Could you explain? Is it not the host IP, where bungeecord listens for the people logging in? thus what would it have to do with one of the servers?
    Now in bungeecord.config I have
    Code (Text):
    prison:
        address: 172.23.70.132:25572
    And in the spigot config on the remote machine correspondingly
    Code (Text):
    bungeecord-addresses:
      - 172.23.70.130
    Should this not be sufficient for bungee and spigot to work together?
     
  6. Change config.yml in bungeecord to

    listeners:
    - max_players: 500
    host: 72.8.141.121:25565 (This limits the talking to just the 72.8.141.121 ip)

    listeners:
    - max_players: 500
    host: 0.0.0.0:25565 (This allows all IP's on the box to be open)
     
  7. Thank you so much! This fixed it :D
     
  8. Cool. Your welcome.
     
  9. Sorry to dig up an old thread, but I've run across this same issue on a Spigot 1.7 install. Two physical servers, connected with a cross over cable on the 2nd nic, giving us a private network. Bungee worked fine with multiple spigot servers on the same server, but when trying to connect a spigot server on the 2nd host, we were getting the io.netty.channel.ConnectTimeoutException error.

    Changing bungee to listen on 0.0.0.0 resolves the problem, but then it listens on all 6 IP's assigned to that host, on the default mc port, which is bad, we can run other versions, etc on the other IP's.

    All I changed in the bungee config.yml was the host: listener IP, we have no firewall and the spigot/bukkit configs were not changed.

    Any help would be appreciated.
    Thanks
     
  10. Should make your own thread.