1.7/1.8+ Compatibility?

Discussion in 'Spigot Help' started by NiceWalls, Apr 22, 2017.

  1. Hello,

    My server is currently running PaperSpigot for Minecraft 1.8.8.

    I have been looking around and all protocol hack plugins require me to have a 1.11 spigot version and then to use their plugin, which allows 1.8+ clients to join.
    I was wondering if I can make my server 1.7 compatible without changing the spigot version to 1.11 and then allowing 1.8?

    I have already tried plugins like ProtocolSupport and Carbon, but like I said, they require a 1.11 spigot version
    (unless I'm doing something wrong)

    Thank you.
     
    #1 NiceWalls, Apr 22, 2017
    Last edited: Apr 24, 2017
  2. if you are moving because of the pvp problems there are alot of plugins fixing it, and also, why would you move to 1.7? there is no support on that version anymore and also, i think that most of your plugins will break since there was allot of change between 1.7 and 1.8 and higher
     
  3. The thing is: I don't want to move to 1.7

    I just want to allow clients from 1.7.10 to be able to join my 1.8 spigot server.
    Many players normally play on 1.7.10 for the pvp.

    How do a lot of networks allow clients to play on 1.7.10?
     
  4. you can with 1.7 and 1.8, not 1.7 and 1.9 or higher (i think).
     
  5. How so? I tried the plugin protocol hack way.
     
  6. ProtocolSupport works and allows <1.7 clients to connect on 1.8.
     
  7. So, on my 1.8.8 spigot server I can use ProtocolSupport, I don't have to use 1.11 spigot?
    Using the latest spigot version breaks most of the essential plugins, so I reverted back to using 1.8.8 spigot.
     
  8. You need the old version of ProtocolSupport, which I can't seem to find anywhere...