[1.8-1.15] BungeeCord

Discussion in 'BungeeCord Discussion' started by md_5, Jan 20, 2013.

  1. We have two servers (A,B) with the same Spigot version. The first jump (A->B) after login is ok, but if i try to jump back (B->A) i get this error:

    Internal Exception: java.lang.ClassCastException:
    cpw.mods.fml.common.network.hardshake.FMLHandshakeMessage$HandshakeReset cannot be cast to cpw.mods.fml.common.network.hardshake.FMLHandshakeMessage$serverHello

    After reconnect i log in the correct destination server (A).

    Bungee: BungeeCord-Bootstrap:1.8-SNAPSHOT:"cfad2c6":1013
    Spigot: spigot-20140927a.jar
    Client: forge 10.13.1.1222
     
    • Agree Agree x 1
  2. I don't get this error but I have socket coms set up across all the servers...Look at ancient gates plugin if you want a tutorial on how to set these up.
     
  3. With vanilla client i can jump from server to server without problem. I get the error only with a modded client (forge and some client only mods).
     
  4. Sry, I don't know anything about modded clients and how they work. The only thing I use is Magic Launcher and it works fine as well.
     
  5. I can't do Proxy Connection please help me
     
  6. i still have problems, players that susing 1.8 cant se players that are using 1.7.
    can it be solved?
     
  7. hmm after watching the videos I get the feeling that this can not allow multiple server applications to be running the same server and update them all as being changed by players, so that a player range higher than your single machine's resources can be achieved?
     
  8. If i protected my bungeecord from ddos attack, but other servers that connected to bungeecord were not. Then, will my other servers attack by ddos while i'm using spigot and inside spigot.yml, bungee-cord was set to true
     
  9. @The_Potion_Man
    25.11 21:48:40 [Server] SEVERE java.lang.IllegalArgumentException: Default server lobby is not defined

    You have default_server: lobby

    There is no "lobby" server under servers:.
     
  10. @md_5 Does the current version of Bungeecord support the new version if spigot 1.8?
     
  11. It's in the title of the thread...
     
  12. Why???
     

    Attached Files:

    • d.jpg
      d.jpg
      File size:
      122.9 KB
      Views:
      179
  13. It literally says how to fix it in the error message...
     
  14. Is there anyway to use 1.8 client -> 1.8 bungeecord -> 1.7.2 server? It gives me an error, while 1.8 client -> 1.8 bungeecord -> 1.7.10 works fine, but I have a couple of servers on my network I'd rather keep 1.7.2 for plugin compatibility.
     
  15. How I can fix that :)
     
  16.  
  17. Thank you alot for developing this I used to use Bukkit because its official but now i will use BungeeCord Because I can see it will better for my server with less glitchs
     
  18. You can't replace Bukkit with BungeeCord, you should replace Bukkit with Spigot.
     
  19. what i said wasn't exactly what i ment