1.8 Rank Plugin Error [Solved]

Discussion in 'Spigot Plugin Development' started by Ant, Jul 2, 2015.

  1. Ant

    Ant

    Heyo, I recently started creating a ranks plugin, but for some reason when I try to run the command in game I get a strange error. The plugin loads up fine, and the error only happens when it's run. Also, the command displays it's usage when it is put in right, (/Rank <player> <rank>) But the error happens when only /rank is entered. I have gone through multiple times, bat have not been able to find anything wrong. Ant help is greatly appreciated!

    ~Ant_ ^-^

    Main Class: http://hastebin.com/agibefator.avrasm
    Plugin.yml: http://hastebin.com/owofizukok.hs
    Error In-Game: http://hastebin.com/iduvezucaq.profile
     
  2. Creeoer

    Supporter

    You should check the args.length as you are getting an arrays out of bounds expection which mean the array doesn't exist. So like if args.length == 0 return false and send a message or whatever.
     
  3. Ant

    Ant

    Okay, thank fixed it. Thanks!